mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
b634b5c253
* gnu/packages/bootloaders.scm (vboot-utils)[source]: Add patches. [arguments]: Conditionally add "HOST_ARCH=arm" to #:make-flags. * gnu/packages/patches/vboot-utils-fix-format-load-address.patch, gnu/packages/patches/vboot-utils-fix-tests-show-contents.patch, gnu/packages/patches/vboot-utils-skip-test-workbuf.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
21 lines
702 B
Diff
21 lines
702 B
Diff
This patch was copied from Debian.
|
|
|
|
Description: skip the workbuf test if VB2_WORKBUF_ALIGN different from 16
|
|
Author: Sophie Brun <sophie@freexian.com>
|
|
Last-Update: 2015-12-03
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
--- a/tests/vb2_common_tests.c
|
|
+++ b/tests/vb2_common_tests.c
|
|
@@ -70,6 +70,11 @@ static void test_workbuf(void)
|
|
/* NOTE: There are several magic numbers below which assume that
|
|
* VB2_WORKBUF_ALIGN == 16 */
|
|
|
|
+ /* Skip the tests if VB2_WORKBUF_ALIGN != 16 */
|
|
+ if (VB2_WORKBUF_ALIGN != 16) {
|
|
+ return;
|
|
+ }
|
|
+
|
|
/* Init */
|
|
vb2_workbuf_init(&wb, p0, 64);
|
|
TEST_EQ(vb2_offset_of(p0, wb.buf), 0, "Workbuf init aligned");
|