mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
e43e980f84
* gnu/packages/patches/aegisub-make43.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/video.scm (aegisub)[source](patches): Add it.
20 lines
674 B
Diff
20 lines
674 B
Diff
Fix build with GNU Make 4.3:
|
|
|
|
https://github.com/Aegisub/Aegisub/issues/171
|
|
|
|
Patch taken from upstream:
|
|
|
|
https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39
|
|
|
|
diff --git a/Makefile.target b/Makefile.target
|
|
--- a/Makefile.target
|
|
+++ b/Makefile.target
|
|
@@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
|
|
# Libraries contain all object files they depend on (but they may depend on other files)
|
|
# Not using libtool on OS X because it has an unsilenceable warning about a
|
|
# compatibility issue with BSD 4.3 (wtf)
|
|
-lib%.a: $$($$*_OBJ)
|
|
+lib%.a: $$($$(*F)_OBJ)
|
|
@$(BIN_MKDIR_P) $(dir $@)
|
|
$(BIN_AR) cru $@ $(filter %.o,$^)
|
|
$(BIN_RANLIB) $@
|