mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
7a1b2ba545
* gnu/packages/gnuzilla.scm (%icecat-version): Update. (%icecat-build-id): New variable. (icecat-source): Update gnuzilla repo commit and hash. (icecat)[arguments]: In the custom 'configure' phase, set the MOZ_BUILD_DATE environment variable to the value of %icecat-build-id. * gnu/packages/patches/icecat-gnuzilla-fixes.patch: Remove changes that are now in the upstream repository. Add more pending changes, including disabling the MOZ_SERVICES_HEALTHREPORT and MOZ_BLOCK_PROFILE_DOWNGRADE build flags, fixing a problem that prevented MOZ_DATA_REPORTING from being disabled, and fixes to the branding. * gnu/packages/patches/icecat-makeicecat.patch: Adapt to upstream changes, and changes in icecat-gnuzilla-fixes.patch. Remove a hunk that disabled rewrites to aboutRights.dtd in the l10n directory.
110 lines
4.2 KiB
Diff
110 lines
4.2 KiB
Diff
Make some of the changes needed to the 'makeicecat' script, to allow it to run
|
|
in a snippet without network access. After this patch is applied, some
|
|
additional changes will be made using 'substitute*'.
|
|
|
|
diff --git a/makeicecat b/makeicecat
|
|
index b04c731..06d1f3f 100644
|
|
--- a/makeicecat
|
|
+++ b/makeicecat
|
|
@@ -30,55 +30,55 @@ SOURCEDIR=icecat-$FFVERSION
|
|
|
|
DATA="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )"/data
|
|
|
|
-mkdir -p output
|
|
-cd output
|
|
+# mkdir -p output
|
|
+# cd output
|
|
|
|
###############################################################################
|
|
# Retrieve FF source code
|
|
###############################################################################
|
|
|
|
-rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
|
|
-
|
|
-wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
|
|
-wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
-gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
|
-gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
-echo -n 85f1c2eaf68ebedcbc0b78a342f6d16ef0865dedd426a1bba94b75c85f716f38 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
|
-
|
|
-echo Extracting Firefox tarball
|
|
-tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
|
-
|
|
-mv firefox-${FFVERSION} $SOURCEDIR
|
|
+# rm mozilla-esr${FFMAJOR} $SOURCEDIR -rf
|
|
+#
|
|
+# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz
|
|
+# wget -N https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${FFVERSION}esr/source/firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
+# gpg --recv-keys --keyserver keyserver.ubuntu.com 14F26682D0916CDD81E37B6D61B7B526D98F0353
|
|
+# gpg --verify firefox-${FFVERSION}esr.source.tar.xz.asc
|
|
+# echo -n 85f1c2eaf68ebedcbc0b78a342f6d16ef0865dedd426a1bba94b75c85f716f38 firefox-${FFVERSION}esr.source.tar.xz |sha256sum -c -
|
|
+#
|
|
+# echo Extracting Firefox tarball
|
|
+# tar -xf firefox-${FFVERSION}esr.source.tar.xz
|
|
+#
|
|
+# mv firefox-${FFVERSION} $SOURCEDIR
|
|
|
|
###############################################################################
|
|
# Retrieve l10n
|
|
###############################################################################
|
|
|
|
-mkdir l10n
|
|
-cd l10n
|
|
-while read line;do
|
|
- line=$(echo $line |cut -d' ' -f1)
|
|
- #[ $line = "es-ES" ] || continue # To speed up testing
|
|
- [ $line = "en-US" ] && continue
|
|
- hg clone https://hg.mozilla.org/l10n-central/$line
|
|
- mkdir -p $line/browser/chrome/browser/preferences
|
|
- touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
|
|
- rm -rf $line/.hg*
|
|
-done < ../$SOURCEDIR/browser/locales/shipped-locales
|
|
-cd ..
|
|
-
|
|
-mv l10n $SOURCEDIR
|
|
-
|
|
-hg clone http://hg.mozilla.org/l10n/compare-locales/
|
|
-cd compare-locales/
|
|
-hg checkout RELEASE_3_3_0
|
|
-cd ..
|
|
-rm compare-locales/.hg* compare-locales/.git* -rf
|
|
-mv compare-locales $SOURCEDIR/l10n
|
|
+# mkdir l10n
|
|
+# cd l10n
|
|
+# while read line;do
|
|
+# line=$(echo $line |cut -d' ' -f1)
|
|
+# #[ $line = "es-ES" ] || continue # To speed up testing
|
|
+# [ $line = "en-US" ] && continue
|
|
+# hg clone https://hg.mozilla.org/l10n-central/$line
|
|
+# mkdir -p $line/browser/chrome/browser/preferences
|
|
+# touch $line/browser/chrome/browser/preferences/advanced-scripts.dtd
|
|
+# rm -rf $line/.hg*
|
|
+# done < ../$SOURCEDIR/browser/locales/shipped-locales
|
|
+# cd ..
|
|
+#
|
|
+# mv l10n $SOURCEDIR
|
|
+#
|
|
+# hg clone http://hg.mozilla.org/l10n/compare-locales/
|
|
+# cd compare-locales/
|
|
+# hg checkout RELEASE_3_3_0
|
|
+# cd ..
|
|
+# rm compare-locales/.hg* compare-locales/.git* -rf
|
|
+# mv compare-locales $SOURCEDIR/l10n
|
|
|
|
#######################################################
|
|
|
|
-cd $SOURCEDIR
|
|
+# cd $SOURCEDIR
|
|
|
|
shopt -s nullglob
|
|
for patch in $DATA/patches/*.patch; do
|
|
@@ -598,6 +598,6 @@ sed 's/777/755/;' -i toolkit/crashreporter/google-breakpad/Makefile.in
|
|
# Fix CVE-2012-3386
|
|
/bin/sed 's/chmod a+w/chmod u+w/' -i ./js/src/ctypes/libffi/Makefile.in ./toolkit/crashreporter/google-breakpad/Makefile.in ./toolkit/crashreporter/google-breakpad/src/third_party/glog/Makefile.in || true
|
|
|
|
-cd ..
|
|
-echo Packaging tarball
|
|
-tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR
|
|
+# cd ..
|
|
+# echo Packaging tarball
|
|
+# tar cfj icecat-$ICECATVERSION.tar.bz2 $SOURCEDIR
|