mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
261422e745
* gnu/packages/racket.scm (%racket-origin): Add patch. * gnu/packages/patches/racket-rktboot-riscv64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
15 lines
890 B
Diff
15 lines
890 B
Diff
Submitted upstream:
|
|
https://github.com/racket/racket/pull/4703
|
|
|
|
diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
|
|
index 8ff0688..59ebfc8 100644
|
|
--- a/racket/src/rktboot/machine-def.rkt
|
|
+++ b/racket/src/rktboot/machine-def.rkt
|
|
@@ -25,6 +25,7 @@
|
|
[(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
|
|
[(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
|
|
[(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
|
|
+ [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
|
|
[(regexp-match? #rx"^t?pb" target-machine) "pb"]
|
|
[else (error "machine.def: cannot infer architecture")]))]
|
|
[s (regexp-replace* #rx"[$][(]Mend[)]" s
|