guix/gnu/packages/patches/racket-rktboot-riscv64-support.patch
Efraim Flashner 261422e745
chez-sheme-for-racket: Fix building on riscv64-linux.
* gnu/packages/racket.scm (%racket-origin): Add patch.
* gnu/packages/patches/racket-rktboot-riscv64-support.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
2023-07-21 13:19:30 +03:00

15 lines
890 B
Diff

Submitted upstream:
https://github.com/racket/racket/pull/4703
diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
index 8ff0688..59ebfc8 100644
--- a/racket/src/rktboot/machine-def.rkt
+++ b/racket/src/rktboot/machine-def.rkt
@@ -25,6 +25,7 @@
[(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
[(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
[(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
+ [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
[(regexp-match? #rx"^t?pb" target-machine) "pb"]
[else (error "machine.def: cannot infer architecture")]))]
[s (regexp-replace* #rx"[$][(]Mend[)]" s