mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
880a316591
* gnu/packages/patches/anki-mpv-args.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/education.scm (anki): Adjust accordingly, wrap anki's PATH to include mpv executable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
Modified from upstream commit:
|
|
https://github.com/ankitects/anki/commit/ccd715013609133c55e83924734efa78abc03326
|
|
Fixes mpv argument syntax (support for old syntax removed in mpv 0.31):
|
|
https://anki.tenderapp.com/discussions/ankidesktop/38186-mpvprocesserror-unable-to-start-process
|
|
Necessary because we are currently unable to upgrade anki to the
|
|
latest version in guix (NPM dependencies currently unpackaged).
|
|
---
|
|
anki/mpv.py | 4 ++--
|
|
anki/sound.py | 1 -
|
|
2 files changed, 2 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/anki/mpv.py b/anki/mpv.py
|
|
index f53d9d0..563fddc 100644
|
|
--- a/anki/mpv.py
|
|
+++ b/anki/mpv.py
|
|
@@ -104,9 +104,9 @@ class MPVBase:
|
|
"""
|
|
self.argv = [self.executable]
|
|
self.argv += self.default_argv
|
|
- self.argv += ["--input-ipc-server", self._sock_filename]
|
|
+ self.argv += ["--input-ipc-server="+self._sock_filename]
|
|
if self.window_id is not None:
|
|
- self.argv += ["--wid", str(self.window_id)]
|
|
+ self.argv += ["--wid="+str(self.window_id)]
|
|
|
|
def _start_process(self):
|
|
"""Start the mpv process.
|
|
diff --git a/anki/sound.py b/anki/sound.py
|
|
index aa3431b..a5fce44 100644
|
|
--- a/anki/sound.py
|
|
+++ b/anki/sound.py
|
|
@@ -124,7 +124,6 @@ class MpvManager(MPV):
|
|
def setMpvConfigBase(base):
|
|
mpvConfPath = os.path.join(base, "mpv.conf")
|
|
MpvManager.default_argv += [
|
|
- "--no-config",
|
|
"--include="+mpvConfPath,
|
|
]
|
|
|
|
--
|
|
2.25.1
|
|
|