mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
a8e149434e
Patches should fix all CVEs reported by `guix lint`: CVE-2015-7747; CVE-2017-6827, CVE-2017-6828, CVE-2017-6829, CVE-2017-6830, CVE-2017-6831, CVE-2017-6832, CVE-2017-6833, CVE-2017-6834, CVE-2017-6835, CVE-2017-6836, CVE-2017-6837, CVE-2017-6838, CVE-2017-6839; CVE-2018-13440; CVE-2018-17095 Since the patches do not reference to CVEs, it's a bit hard to tell which patch actually closes which CVE. Debian reports all these to be closed by the patches below and NixPkgs provides references. * gnu/packages/audio.scm (audiofile): New variable. * gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch, gnu/packages/patches/audiofile-fix-sign-conversion.patch, gnu/packages/patches/audiofile-CVE-2015-7747.patch, gnu/packages/patches/audiofile-CVE-2018-13440.patch, gnu/packages/patches/audiofile-CVE-2018-17095.patch, gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch, gnu/packages/patches/audiofile-Fail-on-error-in-parseFormat.patch, gnu/packages/patches/audiofile-Fix-index-overflow-in-IMA.cpp.patch, gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch, gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch, gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch, gnu/packages/patches/audiofile-hurd.patch, gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: New files. * gnu/local.mk: Add them.
21 lines
826 B
Diff
21 lines
826 B
Diff
From: Antonio Larrosa <larrosa@kde.org>
|
|
Date: Thu, 9 Mar 2017 10:21:18 +0100
|
|
Subject: Check for division by zero in BlockCodec::runPull
|
|
|
|
---
|
|
libaudiofile/modules/BlockCodec.cpp | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/libaudiofile/modules/BlockCodec.cpp b/libaudiofile/modules/BlockCodec.cpp
|
|
index 4731be1..eb2fb4d 100644
|
|
--- a/libaudiofile/modules/BlockCodec.cpp
|
|
+++ b/libaudiofile/modules/BlockCodec.cpp
|
|
@@ -47,7 +47,7 @@ void BlockCodec::runPull()
|
|
|
|
// Read the compressed data.
|
|
ssize_t bytesRead = read(m_inChunk->buffer, m_bytesPerPacket * blockCount);
|
|
- int blocksRead = bytesRead >= 0 ? bytesRead / m_bytesPerPacket : 0;
|
|
+ int blocksRead = (bytesRead >= 0 && m_bytesPerPacket > 0) ? bytesRead / m_bytesPerPacket : 0;
|
|
|
|
// Decompress into m_outChunk.
|
|
for (int i=0; i<blocksRead; i++)
|