mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-17 04:07:10 -05:00
628a6c51d4
* gnu/packages/patches/qemu-meson-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/virtualization.scm (qemu)[source](patches): Add it.
27 lines
1 KiB
Diff
27 lines
1 KiB
Diff
Fix a build failure that occurs with newer versions of Meson when
|
|
gdbus-codegen is unavailable.
|
|
|
|
Taken from upstream:
|
|
https://gitlab.com/qemu-project/qemu/-/commit/5ecfb76ccc056eb6127e44268e475827ae73b9e0
|
|
|
|
diff --git a/configure b/configure
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -3341,7 +3341,7 @@ if ! test "$gio" = "no"; then
|
|
gio_cflags=$($pkg_config --cflags gio-2.0)
|
|
gio_libs=$($pkg_config --libs gio-2.0)
|
|
gdbus_codegen=$($pkg_config --variable=gdbus_codegen gio-2.0)
|
|
- if [ ! -x "$gdbus_codegen" ]; then
|
|
+ if ! has "$gdbus_codegen"; then
|
|
gdbus_codegen=
|
|
fi
|
|
# Check that the libraries actually work -- Ubuntu 18.04 ships
|
|
@@ -5704,6 +5704,8 @@ if test "$gio" = "yes" ; then
|
|
echo "CONFIG_GIO=y" >> $config_host_mak
|
|
echo "GIO_CFLAGS=$gio_cflags" >> $config_host_mak
|
|
echo "GIO_LIBS=$gio_libs" >> $config_host_mak
|
|
+fi
|
|
+if test "$gdbus_codegen" != "" ; then
|
|
echo "GDBUS_CODEGEN=$gdbus_codegen" >> $config_host_mak
|
|
fi
|
|
echo "CONFIG_TLS_PRIORITY=\"$tls_priority\"" >> $config_host_mak
|