mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 11:25:22 -05:00
91675d5082
* gnu/packages/rsync.scm (rsync)[source]: Add patches. [properties]: Mark CVE-2017-15994 as not relevant. * gnu/packages/patches/rsync-CVE-2017-16548.patch, gnu/packages/patches/rsync-CVE-2017-17433.patch, gnu/packages/patches/rsync-CVE-2017-17433-fix-tests.patch, gnu/packages/patches/rsync-CVE-2017-17434-pt1.patch, gnu/packages/patches/rsync-CVE-2017-17434-pt2.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them.
28 lines
891 B
Diff
28 lines
891 B
Diff
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-17434
|
|
https://git.samba.org/?p=rsync.git;a=patch;h=5509597decdbd7b91994210f700329d8a35e70a1
|
|
|
|
From 5509597decdbd7b91994210f700329d8a35e70a1 Mon Sep 17 00:00:00 2001
|
|
From: Jeriko One <jeriko.one@gmx.us>
|
|
Date: Thu, 16 Nov 2017 17:26:03 -0800
|
|
Subject: [PATCH] Check daemon filter against fnamecmp in recv_files().
|
|
|
|
---
|
|
receiver.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/receiver.c b/receiver.c
|
|
index 9fdafa1..9c46242 100644
|
|
--- a/receiver.c
|
|
+++ b/receiver.c
|
|
@@ -722,7 +722,7 @@ int recv_files(int f_in, int f_out, char *local_name)
|
|
break;
|
|
}
|
|
if (!fnamecmp || (daemon_filter_list.head
|
|
- && check_filter(&daemon_filter_list, FLOG, fname, 0) < 0)) {
|
|
+ && check_filter(&daemon_filter_list, FLOG, fnamecmp, 0) < 0)) {
|
|
fnamecmp = fname;
|
|
fnamecmp_type = FNAMECMP_FNAME;
|
|
}
|
|
--
|
|
1.9.1
|
|
|