mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-17 12:17:10 -05:00
689d88451e
* gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 87. (arch-patch, %arch-revision, %arch-patches): Remove. (ungoogled-chromium-snippet): Remove %ARCH-PATCHES. (%ungoogled-revision): Set to 1f7cdef6dfa8f612afde8f988131f210612333e0. (%chromium-version): Set to 87.0.4280.66. (ungoogled-chromium)[source]: Update hash. [arguments]: Adjust #:configure-flags for changes in 87. Enable Pipewire support in WebRTC. [native-inputs]: Add WAYLAND. [inputs]: Add PIPEWIRE and WAYLAND. (ungoogled-chromium/wayland): Implement as a wrapper over UNGOOGLED-CHROMIUM. * gnu/packages/patches/ungoogled-chromium-system-nspr.patch: Adjust for 87.
120 lines
3.1 KiB
Diff
120 lines
3.1 KiB
Diff
Build with the system nspr library.
|
|
|
|
Originally based on a Debian patch:
|
|
https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/nspr.patch
|
|
|
|
--- a/base/time/pr_time_unittest.cc
|
|
+++ b/base/time/pr_time_unittest.cc
|
|
@@ -7,7 +7,7 @@
|
|
|
|
#include "base/compiler_specific.h"
|
|
#include "base/stl_util.h"
|
|
-#include "base/third_party/nspr/prtime.h"
|
|
+#include <nspr/prtime.h>
|
|
#include "base/time/time.h"
|
|
#include "build/build_config.h"
|
|
#include "testing/gtest/include/gtest/gtest.h"
|
|
--- a/base/time/time.cc
|
|
+++ b/base/time/time.cc
|
|
@@ -14,7 +14,7 @@
|
|
#include "base/optional.h"
|
|
#include "base/strings/string_util.h"
|
|
#include "base/strings/stringprintf.h"
|
|
-#include "base/third_party/nspr/prtime.h"
|
|
+#include <nspr/prtime.h>
|
|
#include "base/time/time_override.h"
|
|
#include "build/build_config.h"
|
|
|
|
--- a/base/BUILD.gn
|
|
+++ b/base/BUILD.gn
|
|
@@ -102,6 +102,9 @@
|
|
"-Wglobal-constructors",
|
|
]
|
|
}
|
|
+ ldflags = [
|
|
+ "-lnspr4",
|
|
+ ]
|
|
}
|
|
|
|
config("base_implementation") {
|
|
@@ -720,8 +723,6 @@
|
|
"third_party/cityhash_v103/src/city_v103.h",
|
|
"third_party/icu/icu_utf.cc",
|
|
"third_party/icu/icu_utf.h",
|
|
- "third_party/nspr/prtime.cc",
|
|
- "third_party/nspr/prtime.h",
|
|
"third_party/superfasthash/superfasthash.c",
|
|
"thread_annotations.h",
|
|
"threading/hang_watcher.cc",
|
|
--- a/tools/gn/build/gen.py
|
|
+++ b/tools/gn/build/gen.py
|
|
@@ -380,6 +380,9 @@
|
|
if not options.no_static_libstdcpp:
|
|
ldflags.append('-static-libstdc++')
|
|
|
|
+ # Additional system libraries that are used.
|
|
+ libs.append('-lnspr4')
|
|
+
|
|
if platform.is_mingw() or platform.is_msys():
|
|
cflags.remove('-std=c++17')
|
|
cflags.extend([
|
|
--- a/third_party/blink/renderer/platform/BUILD.gn
|
|
+++ b/third_party/blink/renderer/platform/BUILD.gn
|
|
@@ -110,6 +110,9 @@
|
|
"//build/win:default_exe_manifest",
|
|
"//third_party/icu",
|
|
]
|
|
+ ldflags = [
|
|
+ "-lnspr4"
|
|
+ ]
|
|
}
|
|
|
|
# This isn't strictly necessary since we can just add the deps to "platform",
|
|
--- a/third_party/crashpad/crashpad/handler/BUILD.gn
|
|
+++ b/third_party/crashpad/crashpad/handler/BUILD.gn
|
|
@@ -144,6 +144,9 @@
|
|
"../third_party/mini_chromium:base",
|
|
"../tools:tool_support",
|
|
]
|
|
+ ldflags = [
|
|
+ "-lnspr4"
|
|
+ ]
|
|
|
|
if (crashpad_is_win) {
|
|
if (crashpad_is_in_chromium || crashpad_is_in_dart) {
|
|
--- a/chrome/common/search/BUILD.gn
|
|
+++ b/chrome/common/search/BUILD.gn
|
|
@@ -20,6 +20,9 @@
|
|
"//chrome/common/themes:autogenerated_theme_util",
|
|
"//skia",
|
|
]
|
|
+ ldflags = [
|
|
+ "-lnspr4"
|
|
+ ]
|
|
}
|
|
|
|
compiled_action("generate_chrome_colors_info") {
|
|
--- a/components/url_formatter/spoof_checks/top_domains/BUILD.gn
|
|
+++ b/components/url_formatter/spoof_checks/top_domains/BUILD.gn
|
|
@@ -31,6 +31,9 @@
|
|
"//net/tools/huffman_trie:huffman_trie_generator_sources",
|
|
"//url:url",
|
|
]
|
|
+ ldflags = [
|
|
+ "-lnspr4",
|
|
+ ]
|
|
if (is_ios) {
|
|
frameworks = [ "UIKit.framework" ]
|
|
}
|
|
--- a/components/schema_org/BUILD.gn
|
|
+++ b/components/schema_org/BUILD.gn
|
|
@@ -33,6 +33,9 @@
|
|
"//base",
|
|
"//url",
|
|
]
|
|
+ ldflags = [
|
|
+ "-lnspr4",
|
|
+ ]
|
|
}
|
|
|
|
compiled_action("schema_org_name_data") {
|