mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
3e59d41df0
Add support for renewing AD membership with adcli. Wrap binaries with LDB_MODULES_PATH. Fix the sss_analyze utility to run without systemd libraries. Add native inputs to generate man pages and run additional tests during build. * gnu/packages/sssd.scm (sssd): Update to 2.7.0. [patches]: Drop patches applied upstream. Add a patch for sss_analyze. [inputs]: Add adcli, bash-minimal, jose, keyutils, libnl, pcre2, python. Drop augeas, pcre. [native-inputs]: Add cmocka, doxygen, gettext-minimal, libfaketime, libtool, openssh, po4a, softhsm. [arguments]: Rewrite in gexp style. Fix configure checks. Remove static library from install. Wrap binaries to set correct paths. * gnu/packages/patches/sssd-collision-with-external-nss-symbol.patch, gnu/packages/patches/sssd-fix-samba-4.15.3.patch, gnu/packages/patches/sssd-fix-samba.patch: Delete files. * gnu/packages/patches/sssd-optional-systemd.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
66 lines
2.2 KiB
Diff
66 lines
2.2 KiB
Diff
Do not attempt to create $localstatedir and $sysconfdir (i.e., /var and /etc)
|
|
upon "make install".
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 0de53a2c8..51ad57bf1 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -58,7 +58,7 @@ sssddatadir = $(datadir)/sssd
|
|
sssdapiplugindir = $(sssddatadir)/sssd.api.d
|
|
sssdtapscriptdir = $(sssddatadir)/systemtap
|
|
krb5snippetsdir = $(sssddatadir)/krb5-snippets
|
|
-dbuspolicydir = $(sysconfdir)/dbus-1/system.d
|
|
+dbuspolicydir = $(prefix)/etc/dbus-1/system.d
|
|
dbusservicedir = $(datadir)/dbus-1/system-services
|
|
sss_statedir = $(localstatedir)/lib/sss
|
|
runstatedir = @runstatedir@
|
|
@@ -85,7 +85,7 @@ pkgconfigdir = $(libdir)/pkgconfig
|
|
krb5rcachedir = @krb5rcachedir@
|
|
sudolibdir = @sudolibpath@
|
|
polkitdir = @polkitdir@
|
|
-pamconfdir = $(sysconfdir)/pam.d
|
|
+pamconfdir = $(prefix)/etc/pam.d
|
|
systemtap_tapdir = @tapset_dir@
|
|
sssdkcmdatadir = $(datadir)/sssd-kcm
|
|
deskprofilepath = $(sss_statedir)/deskprofile
|
|
@@ -5195,7 +5195,6 @@ installsssddirs::
|
|
$(DESTDIR)$(bindir) \
|
|
$(DESTDIR)$(sbindir) \
|
|
$(DESTDIR)$(mandir) \
|
|
- $(DESTDIR)$(pidpath) \
|
|
$(DESTDIR)$(pluginpath) \
|
|
$(DESTDIR)$(libdir)/ldb \
|
|
$(DESTDIR)$(dbuspolicydir) \
|
|
@@ -5205,24 +5204,12 @@ installsssddirs::
|
|
$(DESTDIR)$(sssddatadir) \
|
|
$(DESTDIR)$(sudolibdir) \
|
|
$(DESTDIR)$(autofslibdir) \
|
|
- $(DESTDIR)$(pipepath)/private \
|
|
$(DESTDIR)$(krb5snippetsdir) \
|
|
- $(SSSD_USER_DIRS) \
|
|
$(NULL);
|
|
if SSSD_USER
|
|
-chown $(SSSD_USER):$(SSSD_USER) $(SSSD_USER_DIRS)
|
|
-chown $(SSSD_USER) $(DESTDIR)$(pipepath)/private
|
|
endif
|
|
- $(INSTALL) -d -m 0700 $(DESTDIR)$(dbpath) $(DESTDIR)$(logpath) \
|
|
- $(DESTDIR)$(keytabdir) \
|
|
- $(NULL)
|
|
- $(INSTALL) -d -m 0750 $(DESTDIR)$(pipepath)/private
|
|
- $(INSTALL) -d -m 0755 $(DESTDIR)$(mcpath) $(DESTDIR)$(pipepath) \
|
|
- $(DESTDIR)$(pubconfpath) \
|
|
- $(DESTDIR)$(pubconfpath)/krb5.include.d $(DESTDIR)$(gpocachepath)
|
|
- $(INSTALL) -d -m 0711 $(DESTDIR)$(sssdconfdir) \
|
|
- $(DESTDIR)$(sssdconfdir)/conf.d \
|
|
- $(DESTDIR)$(sssdconfdir)/pki
|
|
|
|
if HAVE_DOXYGEN
|
|
docs:
|
|
@@ -5338,7 +5325,6 @@ if BUILD_SAMBA
|
|
endif
|
|
if BUILD_KCM
|
|
$(MKDIR_P) $(DESTDIR)/$(sssdkcmdatadir)
|
|
- $(MKDIR_P) $(DESTDIR)$(secdbpath)
|
|
endif
|
|
|
|
uninstall-hook:
|