mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
26cb0c3960
* gnu/packages/patches/syslinux-gcc10.patch: New file. * gnu/packages/patches/syslinux-strip-gnu-property.patch: New file. * gnu/local.mk (DIST_PATCH_DATA): Add them. * gnu/packages/bootloaders.scm (syslinux)[source]: Use them. [arguments]: Only strip debug symbols.
31 lines
1.1 KiB
Diff
31 lines
1.1 KiB
Diff
Taken from: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906414.
|
|
|
|
Author: Lukas Schwaighofer <lukas@schwaighofer.name>
|
|
Description: Strip the .note.gnu.property section for the mbr. This section is
|
|
added since binutils Debian version 2.31.1-2 and causes mbr.bin to grow in
|
|
size beyond what can fit into the master boot record.
|
|
---
|
|
mbr/i386/mbr.ld | 1 +
|
|
mbr/x86_64/mbr.ld | 1 +
|
|
2 files changed, 2 insertions(+)
|
|
|
|
diff --git a/mbr/i386/mbr.ld b/mbr/i386/mbr.ld
|
|
index d14ba80..5368346 100644
|
|
--- a/mbr/i386/mbr.ld
|
|
+++ b/mbr/i386/mbr.ld
|
|
@@ -70,4 +70,5 @@ SECTIONS
|
|
.debug_typenames 0 : { *(.debug_typenames) }
|
|
.debug_varnames 0 : { *(.debug_varnames) }
|
|
/DISCARD/ : { *(.note.GNU-stack) }
|
|
+ /DISCARD/ : { *(.note.gnu.property) }
|
|
}
|
|
diff --git a/mbr/x86_64/mbr.ld b/mbr/x86_64/mbr.ld
|
|
index ae27d49..b8c0d89 100644
|
|
--- a/mbr/x86_64/mbr.ld
|
|
+++ b/mbr/x86_64/mbr.ld
|
|
@@ -69,4 +69,5 @@ SECTIONS
|
|
.debug_typenames 0 : { *(.debug_typenames) }
|
|
.debug_varnames 0 : { *(.debug_varnames) }
|
|
/DISCARD/ : { *(.note.GNU-stack) }
|
|
+ /DISCARD/ : { *(.note.gnu.property) }
|
|
}
|