mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
5b0b520e22
* gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Adjust to upstream changes. * gnu/packages/patches/ceph-disable-unittest-throttle.patch: Delete file. * gnu/packages/patches/ceph-rocksdb-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/storage.scm (ceph): Update to 12.2.4. [source](patches): Adjust. [arguments]: Add "-DWITH_BABELTRACE=OFF" in #:configure-flags. Build with CMAKE-3.11. Adjust file substitutions. Wrap 'ceph' executable. [native-inputs]: Add GPERF. [inputs]: Replace BOOST with BOOST-1.66. Add PYTHON2-PRETTYTABLE.
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
Disable CPU optimizations not supported by all x86_64 systems.
|
|
|
|
--- a/cmake/modules/SIMDExt.cmake 2017-03-23 22:22:58.254071694 +0100
|
|
+++ b/cmake/modules/SIMDExt.cmake 2017-03-23 22:23:22.446848845 +0100
|
|
@@ -5,11 +5,6 @@
|
|
# HAVE_ARM_NEON
|
|
# HAVE_INTEL_SSE
|
|
# HAVE_INTEL_SSE2
|
|
-# HAVE_INTEL_SSE3
|
|
-# HAVE_INTEL_SSSE3
|
|
-# HAVE_INTEL_PCLMUL
|
|
-# HAVE_INTEL_SSE4_1
|
|
-# HAVE_INTEL_SSE4_2
|
|
#
|
|
# SIMD_COMPILE_FLAGS
|
|
#
|
|
@@ -85,26 +80,6 @@
|
|
if(HAVE_INTEL_SSE2)
|
|
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse2")
|
|
endif()
|
|
- CHECK_C_COMPILER_FLAG(-msse3 HAVE_INTEL_SSE3)
|
|
- if(HAVE_INTEL_SSE3)
|
|
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse3")
|
|
- endif()
|
|
- CHECK_C_COMPILER_FLAG(-mssse3 HAVE_INTEL_SSSE3)
|
|
- if(HAVE_INTEL_SSSE3)
|
|
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mssse3")
|
|
- endif()
|
|
- CHECK_C_COMPILER_FLAG(-mpclmul HAVE_INTEL_PCLMUL)
|
|
- if(HAVE_INTEL_PCLMUL)
|
|
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mpclmul")
|
|
- endif()
|
|
- CHECK_C_COMPILER_FLAG(-msse4.1 HAVE_INTEL_SSE4_1)
|
|
- if(HAVE_INTEL_SSE4_1)
|
|
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.1")
|
|
- endif()
|
|
- CHECK_C_COMPILER_FLAG(-msse4.2 HAVE_INTEL_SSE4_2)
|
|
- if(HAVE_INTEL_SSE4_2)
|
|
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.2")
|
|
- endif()
|
|
endif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
|
|
endif(CMAKE_SYSTEM_PROCESSOR MATCHES "i686|amd64|x86_64|AMD64")
|
|
elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "(powerpc|ppc)64le")
|