mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
4732e6ee84
* gnu/packages/bioinformatics.scm (blast+): Update to 2.6.0. [origin]: Remove bundled pcre. Add patch. [arguments]: Replace paths in run_with_lock.c. Configure with pcre. [inputs]: Add pcre, perl, python. * gnu/packages/patches/blast+-fix-makefile.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
15 lines
626 B
Diff
15 lines
626 B
Diff
Without this patch, the 'make install' attempts to 'install' a directory, which causes an error.
|
|
|
|
diff --git a/c++/src/build-system/Makefile.in.top b/c++/src/build-system/Makefile.in.top
|
|
index 1abe44f..d6000b3 100644
|
|
--- a/c++/src/build-system/Makefile.in.top
|
|
+++ b/c++/src/build-system/Makefile.in.top
|
|
@@ -51,7 +51,7 @@ install-toolkit:
|
|
done
|
|
cd $(includedir0) && find * -name CVS -prune -o -print |\
|
|
cpio -pd $(pincludedir)
|
|
- $(INSTALL) -m 644 $(incdir)/* $(pincludedir)
|
|
+ cp -R $(incdir)/* $(pincludedir)
|
|
## set up appropriate build and status directories somewhere under $(libdir)?
|
|
|
|
install-gbench:
|