mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 03:45:24 -05:00
9e46245b89
* gnu/packages/patches/gst-plugins-good-fix-crashes.patch, gnu/packages/patches/gst-plugins-good-fix-invalid-read.patch, gnu/packages/patches/gst-plugins-good-fix-signedness.patch, gnu/packages/patches/gst-plugins-good-flic-bounds-check.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gstreamer.scm (gst-plugins-good): Use them.
58 lines
2.1 KiB
Diff
58 lines
2.1 KiB
Diff
This is a followup fix for upstream bug #774834 (flic decoder: Buffer overflow
|
||
in flx_decode_delta_fli):
|
||
|
||
https://bugzilla.gnome.org/show_bug.cgi?id=774834#c2
|
||
|
||
Patch copied from upstream source repository:
|
||
|
||
https://cgit.freedesktop.org/gstreamer/gst-plugins-good/commit/?id=1ab2b26193861b124426e2f8eb62b75b59ec5488
|
||
|
||
From 1ab2b26193861b124426e2f8eb62b75b59ec5488 Mon Sep 17 00:00:00 2001
|
||
From: Matthew Waters <matthew@centricular.com>
|
||
Date: Tue, 22 Nov 2016 23:46:00 +1100
|
||
Subject: [PATCH] flxdec: fix some warnings comparing unsigned < 0
|
||
MIME-Version: 1.0
|
||
Content-Type: text/plain; charset=UTF-8
|
||
Content-Transfer-Encoding: 8bit
|
||
|
||
bf43f44fcfada5ec4a3ce60cb374340486fe9fac was comparing an unsigned
|
||
expression to be < 0 which was always false.
|
||
|
||
gstflxdec.c: In function ‘flx_decode_brun’:
|
||
gstflxdec.c:322:33: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits]
|
||
if ((glong) row - count < 0) {
|
||
^
|
||
gstflxdec.c:332:33: warning: comparison of unsigned expression < 0 is always false [-Wtype-limits]
|
||
if ((glong) row - count < 0) {
|
||
^
|
||
|
||
https://bugzilla.gnome.org/show_bug.cgi?id=774834
|
||
---
|
||
gst/flx/gstflxdec.c | 4 ++--
|
||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||
|
||
diff --git a/gst/flx/gstflxdec.c b/gst/flx/gstflxdec.c
|
||
index d51a8e6..e675c99 100644
|
||
--- a/gst/flx/gstflxdec.c
|
||
+++ b/gst/flx/gstflxdec.c
|
||
@@ -319,7 +319,7 @@ flx_decode_brun (GstFlxDec * flxdec, guchar * data, guchar * dest)
|
||
if (count > 0x7f) {
|
||
/* literal run */
|
||
count = 0x100 - count;
|
||
- if ((glong) row - count < 0) {
|
||
+ if ((glong) row - (glong) count < 0) {
|
||
GST_ERROR_OBJECT (flxdec, "Invalid BRUN packet detected.");
|
||
return FALSE;
|
||
}
|
||
@@ -329,7 +329,7 @@ flx_decode_brun (GstFlxDec * flxdec, guchar * data, guchar * dest)
|
||
*dest++ = *data++;
|
||
|
||
} else {
|
||
- if ((glong) row - count < 0) {
|
||
+ if ((glong) row - (glong) count < 0) {
|
||
GST_ERROR_OBJECT (flxdec, "Invalid BRUN packet detected.");
|
||
return FALSE;
|
||
}
|
||
--
|
||
2.10.2
|
||
|