mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
21b3b75515
* gnu/packages/patches/glib-CVE-2021-27218.patch, gnu/packages/patches/glib-CVE-2021-27219-01.patch, gnu/packages/patches/glib-CVE-2021-27219-02.patch, gnu/packages/patches/glib-CVE-2021-27219-03.patch, gnu/packages/patches/glib-CVE-2021-27219-04.patch, gnu/packages/patches/glib-CVE-2021-27219-05.patch, gnu/packages/patches/glib-CVE-2021-27219-06.patch, gnu/packages/patches/glib-CVE-2021-27219-07.patch, gnu/packages/patches/glib-CVE-2021-27219-08.patch, gnu/packages/patches/glib-CVE-2021-27219-09.patch, gnu/packages/patches/glib-CVE-2021-27219-10.patch, gnu/packages/patches/glib-CVE-2021-27219-11.patch, gnu/packages/patches/glib-CVE-2021-27219-12.patch, gnu/packages/patches/glib-CVE-2021-27219-13.patch, gnu/packages/patches/glib-CVE-2021-27219-14.patch, gnu/packages/patches/glib-CVE-2021-27219-15.patch, gnu/packages/patches/glib-CVE-2021-27219-16.patch, gnu/packages/patches/glib-CVE-2021-27219-17.patch, gnu/packages/patches/glib-CVE-2021-27219-18.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/glib.scm (glib)[replacement]: New field. (glib/fixed): New variable.
30 lines
1,014 B
Diff
30 lines
1,014 B
Diff
From f8273b9aded135fe07094faebd527e43851aaf6e Mon Sep 17 00:00:00 2001
|
||
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
||
Date: Sun, 7 Feb 2021 23:32:40 +0100
|
||
Subject: [PATCH 1/5] giochannel: Fix length_size bounds check
|
||
|
||
The inverted condition is an obvious error introduced by ecdf91400e9a.
|
||
|
||
Fixes https://gitlab.gnome.org/GNOME/glib/-/issues/2323
|
||
|
||
(cherry picked from commit a149bf2f9030168051942124536e303af8ba6176)
|
||
---
|
||
glib/giochannel.c | 2 +-
|
||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||
|
||
diff --git a/glib/giochannel.c b/glib/giochannel.c
|
||
index 66c6591f0..0d9d5f223 100644
|
||
--- a/glib/giochannel.c
|
||
+++ b/glib/giochannel.c
|
||
@@ -897,7 +897,7 @@ g_io_channel_set_line_term (GIOChannel *channel,
|
||
{
|
||
/* FIXME: We’re constrained by line_term_len being a guint here */
|
||
gsize length_size = strlen (line_term);
|
||
- g_return_if_fail (length_size > G_MAXUINT);
|
||
+ g_return_if_fail (length_size <= G_MAXUINT);
|
||
length_unsigned = (guint) length_size;
|
||
}
|
||
|
||
--
|
||
2.30.1
|
||
|