mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
f1b4f46f0a
Partly fixes <https://issues.guix.gnu.org/51088>. * gnu/packages/patches/clang-10.0-libc-search-path.patch: Update.
93 lines
3.8 KiB
Diff
93 lines
3.8 KiB
Diff
Clang attempts to guess file names based on the OS and distro (yes!),
|
|
but unfortunately, that doesn't work for us.
|
|
|
|
This patch makes it easy to insert libc's $libdir so that Clang passes the
|
|
correct absolute file name of crt1.o etc. to 'ld'. It also disables all
|
|
the distro-specific stuff and removes the hard-coded FHS directory names
|
|
to make sure Clang also works on foreign distros.
|
|
|
|
diff --git a/lib/Driver/Distro.cpp b/lib/Driver/Distro.cpp
|
|
index 06707fef..f3bd43de 100644
|
|
--- a/lib/Driver/Distro.cpp
|
|
+++ b/lib/Driver/Distro.cpp
|
|
@@ -20,6 +20,10 @@ using namespace clang;
|
|
|
|
static Distro::DistroType DetectDistro(llvm::vfs::FileSystem &VFS,
|
|
const llvm::Triple &TargetOrHost) {
|
|
+ // The compiler should always behave the same, even when used via Guix on a
|
|
+ // foreign distro.
|
|
+ return Distro::UnknownDistro;
|
|
+
|
|
// If we don't target Linux, no need to check the distro. This saves a few
|
|
// OS calls.
|
|
if (!TargetOrHost.isOSLinux())
|
|
diff --git a/lib/Driver/ToolChains/Cuda.cpp b/lib/Driver/ToolChains/Cuda.cpp
|
|
index 50d22a2a..4ab93e0a 100644
|
|
--- a/lib/Driver/ToolChains/Cuda.cpp
|
|
+++ b/lib/Driver/ToolChains/Cuda.cpp
|
|
@@ -60,6 +60,9 @@ CudaInstallationDetector::CudaInstallationDetector(
|
|
const Driver &D, const llvm::Triple &HostTriple,
|
|
const llvm::opt::ArgList &Args)
|
|
: D(D) {
|
|
+ // Don't look for CUDA in /usr.
|
|
+ return;
|
|
+
|
|
struct Candidate {
|
|
std::string Path;
|
|
bool StrictChecking;
|
|
diff --git a/lib/Driver/ToolChains/Linux.cpp b/lib/Driver/ToolChains/Linux.cpp
|
|
index bff1ab10..e996d3b8 100644
|
|
--- a/lib/Driver/ToolChains/Linux.cpp
|
|
+++ b/lib/Driver/ToolChains/Linux.cpp
|
|
@@ -240,6 +240,9 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
.str());
|
|
}
|
|
|
|
+ // Comment out the distro-specific tweaks so that they don't bite when
|
|
+ // using Guix on a foreign distro.
|
|
+#if 0
|
|
Distro Distro(D.getVFS(), Triple);
|
|
|
|
if (Distro.IsAlpineLinux() || Triple.isAndroid()) {
|
|
@@ -306,6 +309,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
|
|
if (IsAndroid || Distro.IsOpenSUSE())
|
|
ExtraOpts.push_back("--enable-new-dtags");
|
|
+#endif
|
|
|
|
// The selection of paths to try here is designed to match the patterns which
|
|
// the GCC driver itself uses, as this is part of the GCC-compatible driver.
|
|
@@ -369,6 +373,7 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
}
|
|
}
|
|
|
|
+#if 0
|
|
// Similar to the logic for GCC above, if we currently running Clang inside
|
|
// of the requested system root, add its parent library paths to
|
|
// those searched.
|
|
@@ -414,6 +419,8 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
// Try walking via the GCC triple path in case of biarch or multiarch GCC
|
|
// installations with strange symlinks.
|
|
if (GCCInstallation.isValid()) {
|
|
+ // The following code would end up adding things like
|
|
+ // "/usr/lib/x86_64-unknown-linux-gnu/../../lib64" to the search path.
|
|
addPathIfExists(D,
|
|
SysRoot + "/usr/lib/" + GCCInstallation.getTriple().str() +
|
|
"/../../" + OSLibDir,
|
|
@@ -449,9 +456,14 @@ Linux::Linux(const Driver &D, const llvm::Triple &Triple, const ArgList &Args)
|
|
// directory ('Dir' below) or the ResourceDir.
|
|
if (StringRef(D.Dir).startswith(SysRoot))
|
|
addPathIfExists(D, D.Dir + "/../lib", Paths);
|
|
+#endif
|
|
+
|
|
+ // Add libc's lib/ directory to the search path, so that crt1.o, crti.o,
|
|
+ // and friends can be found.
|
|
+ addPathIfExists(D, "@GLIBC_LIBDIR@", Paths);
|
|
|
|
- addPathIfExists(D, SysRoot + "/lib", Paths);
|
|
- addPathIfExists(D, SysRoot + "/usr/lib", Paths);
|
|
+ // Add GCC's lib/ directory so libstdc++.so can be found.
|
|
+ addPathIfExists(D, GCCInstallation.getParentLibPath(), Paths);
|
|
}
|
|
|
|
ToolChain::CXXStdlibType Linux::GetDefaultCXXStdlibType() const {
|