mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
705af5403b
* gnu/packages/maths.scm (superlu-dist): Update to 6.4.0 [source]: Use git-fetch, as tarballs are no longer published. * gnu/packages/patches/superlu-dist-awpm-grid.patch: Remove all but the first hunk; they are unnecessary.
25 lines
1.2 KiB
Diff
25 lines
1.2 KiB
Diff
Create the CombBLAS::SpParMat with the MPI_Comm from the input 'gridinfo_t'.
|
|
This prevents a warning/error from CombBLAS about using MPI_COMM_WORLD.
|
|
|
|
--- a/SRC/dHWPM_CombBLAS.hpp
|
|
+++ b/SRC/dHWPM_CombBLAS.hpp
|
|
@@ -52,7 +52,7 @@
|
|
{
|
|
printf("AWPM only supports square process grid. Retuning without a permutation.\n");
|
|
}
|
|
- combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc;
|
|
+ combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc(grid->comm);
|
|
std::vector< std::vector < std::tuple<int_t,int_t,double> > > data(procs);
|
|
|
|
/* ------------------------------------------------------------
|
|
--- a/SRC/zHWPM_CombBLAS.hpp
|
|
+++ b/SRC/zHWPM_CombBLAS.hpp
|
|
@@ -52,7 +52,7 @@
|
|
{
|
|
printf("AWPM only supports square process grid. Retuning without a permutation.\n");
|
|
}
|
|
- combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc;
|
|
+ combblas::SpParMat < int_t, double, combblas::SpDCCols<int_t,double> > Adcsc(grid->comm);
|
|
std::vector< std::vector < std::tuple<int_t,int_t,double> > > data(procs);
|
|
|
|
/* ------------------------------------------------------------
|