mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 19:35:25 -05:00
a55e2b221c
Fixes <http://bugs.gnu.org/20121>. * gnu/packages/patches/curl-gss-api-fix.patch: Delete file. * gnu/packages/patches/curl-support-capath-on-gnutls.patch, gnu/packages/patches/curl-support-capath-on-gnutls-conf.patch: New files. * gnu-system.am (dist_patch_DATA): Add new patches and remove old one. * gnu/packages/curl.scm (curl): Update to 7.41.0. Add new patches and remove old one. Disable one unit test. Modified-By: Mark H Weaver <mhw@netris.org>
16 lines
795 B
Diff
16 lines
795 B
Diff
This patch updates 'configure' as autoreconf would have done after
|
|
applying curl-support-capath-on-gnutls.patch.
|
|
|
|
--- a/configure 2015-03-22 01:11:23.178743705 +0100
|
|
+++ b/configure 2015-02-25 00:05:37.000000000 +0100
|
|
@@ -23952,8 +24432,8 @@
|
|
ca="$want_ca"
|
|
capath="no"
|
|
elif test "x$want_capath" != "xno" -a "x$want_capath" != "xunset"; then
|
|
- if test "x$OPENSSL_ENABLED" != "x1" -a "x$POLARSSL_ENABLED" != "x1"; then
|
|
- as_fn_error $? "--with-ca-path only works with openSSL or PolarSSL" "$LINENO" 5
|
|
+ if test "x$OPENSSL_ENABLED" != "x1" -a "x$GNUTLS_ENABLED" != "x1" -a "x$POLARSSL_ENABLED" != "x1"; then
|
|
+ as_fn_error $? "--with-ca-path only works with OpenSSL, GnuTLS or PolarSSL" "$LINENO" 5
|
|
fi
|
|
capath="$want_capath"
|
|
ca="no"
|