mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
4467c2d1dc
* gnu/packages/kde-frameworks.scm (breeze-icons): Update to 5.32.0. [arguments]: Re-enable tests. (kio): Update to 5.32.0. [source]: Remove patch. (ktexteditor): Update to 5.32.0. [inputs]: Add ksyntaxhighlighting. (networkmanager-qt): Update to 5.32.0. [source]: Add patches. (kunitconversion): Update to 5.32.0. [arguments] <disable-a-failing-test-case>: New phase. (ksyntaxhighlighting): Update to 5.32.0.[native-iputs]: Add qtools. (knewstuff): Update to 5.32.0. [inputs]: Add qtdeclarative. (attica, baloo, bluez-qt, extra-cmake-modules, kactivities, kactivities-stats, kapidox, karchive, kauth, kbookmarks, kcmutils, kcodecs, kcompletion, kconfig, kconfigwidgets, kcoreaddons, kcrash, kdbusaddons, kdeclarative, kded, kdesignerplugin, kdesu, kdnssd, kdoctools, kemoticons, kfilemetadata, kglobalaccel, kguiaddons, ki18n, kiconthemes, kidletime, kimageformats, kinit, kitemmodels, kitemviews, kjobwidgets, knotifications, knotifyconfig, kpackage, kparts, kpeople, kplotting, kpty, krunner, kservice, ktextwidgets, kwallet, kwayland, kwidgetsaddons, kwindowsystem, kxmlgui, kxmlrpcclient, modemmanager-qt, oxygen-icons, plasma-framework, solid, sonnet, threadweaver): Update to 5.32.0. * gnu/packages/patches/kio-CVE-2017-6410.patch: Delete file. * gnu/packages/patches/networkmanager-qt-activeconnection-test-1.patch, gnu/packages/patches/networkmanager-qt-activeconnection-test-2.patch: New files. * gnu/local.mk (dist_patch_DATA): Remove resp. add the patch files.
57 lines
2.1 KiB
Diff
57 lines
2.1 KiB
Diff
From 3f6155389abc8e2b3dafc5eefa1ce0c929b007fa Mon Sep 17 00:00:00 2001
|
|
From: Jan Grulich <jgrulich@redhat.com>
|
|
Date: Mon, 3 Apr 2017 14:13:54 +0200
|
|
Subject: One more attempt to fix unit test for active connections
|
|
|
|
---
|
|
src/activeconnection.cpp | 10 ++++++++++
|
|
1 file changed, 10 insertions(+)
|
|
|
|
diff --git a/src/activeconnection.cpp b/src/activeconnection.cpp
|
|
index 05582fa..3a8e6b2 100644
|
|
--- a/src/activeconnection.cpp
|
|
+++ b/src/activeconnection.cpp
|
|
@@ -79,11 +79,13 @@ NetworkManager::ActiveConnection::ActiveConnection(const QString &path, QObject
|
|
connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
|
#endif
|
|
|
|
+#ifndef NMQT_STATIC
|
|
/*
|
|
* Workaround: Re-check connection state before we watch changes in case it gets changed too quickly
|
|
* BUG:352326
|
|
*/
|
|
d->recheckProperties();
|
|
+#endif
|
|
}
|
|
|
|
NetworkManager::ActiveConnection::ActiveConnection(ActiveConnectionPrivate &dd, QObject *parent)
|
|
@@ -91,18 +93,26 @@ NetworkManager::ActiveConnection::ActiveConnection(ActiveConnectionPrivate &dd,
|
|
{
|
|
Q_D(ActiveConnection);
|
|
|
|
+#ifndef NMQT_STATIC
|
|
#if NM_CHECK_VERSION(1, 4, 0)
|
|
QDBusConnection::systemBus().connect(NetworkManagerPrivate::DBUS_SERVICE, d->path, NetworkManagerPrivate::FDO_DBUS_PROPERTIES,
|
|
QLatin1String("PropertiesChanged"), d, SLOT(dbusPropertiesChanged(QString,QVariantMap,QStringList)));
|
|
#else
|
|
connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
|
#endif
|
|
+#endif
|
|
+
|
|
+#ifdef NMQT_STATIC
|
|
+ connect(&d->iface, &OrgFreedesktopNetworkManagerConnectionActiveInterface::PropertiesChanged, d, &ActiveConnectionPrivate::propertiesChanged);
|
|
+#endif
|
|
|
|
+#ifndef NMQT_STATIC
|
|
/*
|
|
* Workaround: Re-check connection state before we watch changes in case it gets changed too quickly
|
|
* BUG:352326
|
|
*/
|
|
d->recheckProperties();
|
|
+#endif
|
|
}
|
|
|
|
NetworkManager::ActiveConnection::~ActiveConnection()
|
|
--
|
|
cgit v0.11.2
|
|
|