mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
20fa738123
* gnu/packages/databases.scm (python-hiredis): Update to 2.2.2. [source]: Fetch via git and apply patches. [build-system]: Use pyproject-build-system. [arguments]: Enable tests. Add #:phases. [native-inputs]: New field. [inputs]: Likewise. * gnu/packages/patches/python-hiredis-fix-header.patch: New file. * gnu/packages/patches/python-hiredis-use-system-hiredis.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Register them.
49 lines
1.3 KiB
Diff
49 lines
1.3 KiB
Diff
Upstream status: https://github.com/redis/hiredis-py/pull/159
|
|
|
|
From c2a20695aae53de7b5160e29675344df0b805fa6 Mon Sep 17 00:00:00 2001
|
|
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|
|
Date: Sat, 18 Mar 2023 15:18:08 -0400
|
|
Subject: [PATCH] pack: Replace sdsalloc.h with alloc.h
|
|
|
|
Fixes #158.
|
|
|
|
* src/pack.c: Replace sdsalloc.h with alloc.h.
|
|
(pack_command): Replace s_malloc with hi_malloc.
|
|
---
|
|
src/pack.c | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/src/pack.c b/src/pack.c
|
|
index 443e9d3..23e4004 100644
|
|
--- a/src/pack.c
|
|
+++ b/src/pack.c
|
|
@@ -16,7 +16,7 @@ extern sds sdscpylen(sds s, const char *t, size_t len);
|
|
extern sds sdsnewlen(const void *init, size_t initlen);
|
|
#endif
|
|
|
|
-#include <hiredis/sdsalloc.h>
|
|
+#include <hiredis/alloc.h>
|
|
|
|
PyObject *
|
|
pack_command(PyObject *cmd)
|
|
@@ -32,7 +32,7 @@ pack_command(PyObject *cmd)
|
|
}
|
|
|
|
Py_ssize_t tokens_number = PyTuple_Size(cmd);
|
|
- sds *tokens = s_malloc(sizeof(sds) * tokens_number);
|
|
+ sds *tokens = hi_malloc(sizeof(sds) * tokens_number);
|
|
if (tokens == NULL)
|
|
{
|
|
return PyErr_NoMemory();
|
|
@@ -118,4 +118,4 @@ cleanup:
|
|
sdsfreesplitres(tokens, tokens_number);
|
|
hi_free(lengths);
|
|
return result;
|
|
-}
|
|
\ No newline at end of file
|
|
+}
|
|
|
|
base-commit: 8adb1b3cb38b82cdc73fa2d72879712da1f74e70
|
|
--
|
|
2.39.1
|
|
|