mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
2e433799c5
* gnu/packages/maths.scm (scilab): Update to 2024.1.0. * gnu/packages/patches/scilab-tbx_build_help.patch: Update patch. Change-Id: I79197822aefba698b2383e3aa30fbc511da6954c Signed-off-by: Ludovic Courtès <ludo@gnu.org>
35 lines
1.5 KiB
Diff
35 lines
1.5 KiB
Diff
From 24a9bc240729b7630e20a7b83b75f086024ae03d Mon Sep 17 00:00:00 2001
|
|
From: Nicolas Graves <ngraves@ngraves.fr>
|
|
Date: Wed, 21 Aug 2024 15:42:35 +0200
|
|
Subject: [PATCH] scilab: tbx_build_help: Allow for some flexibility under
|
|
-nwni.
|
|
|
|
upstream reference: https://gitlab.com/scilab/scilab/-/merge_requests/818
|
|
---
|
|
scilab/modules/modules_manager/macros/tbx_build_help.sci | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/scilab/modules/modules_manager/macros/tbx_build_help.sci b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
|
index ab06b3fa8dc..cbb1b4cadf8 100644
|
|
--- a/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
|
+++ b/scilab/modules/modules_manager/macros/tbx_build_help.sci
|
|
@@ -57,8 +57,8 @@ function tbx_build_help(moduletitle, path)
|
|
|
|
// Check scilab mode
|
|
if and(getscilabmode() <> ["STD" "NW"]) then
|
|
- error(msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode()));
|
|
- end
|
|
+ msprintf(gettext("%s: documentation cannot be built in this scilab mode: %s.\n"),"tbx_build_help",getscilabmode());
|
|
+ else
|
|
|
|
directory_language = basename(path);
|
|
default_language = "en_US"
|
|
@@ -89,4 +89,5 @@ function tbx_build_help(moduletitle, path)
|
|
warning(_(".start file was not found, build of help pages using <scilab:image> tag may failed."));
|
|
xmltojar(path, moduletitle, directory_language, default_language);
|
|
end
|
|
+ end
|
|
endfunction
|
|
--
|
|
2.45.2
|
|
|