mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
38988dbecf
* gnu/packages/kde.scm(kpmcore): Update to 4.0.1. [origin]: Add upstream patches for making tests pass. [inputs]: Add qttools. Remove kiconthemes, kservice, libatasmart, parted. [arguments]: New element. * gnu/packages/patches/kpmcore-fix-tests.patch, gnu/packages/patches/kpmcore-remove-broken-test.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. add patches
139 lines
3.5 KiB
Diff
139 lines
3.5 KiB
Diff
From c9a08a593bac8b8610a647db118fea6f2958156d Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
|
|
Date: Thu, 7 Nov 2019 22:12:00 +0000
|
|
Subject: [PATCH] Remove broken smart unit test.
|
|
|
|
BUG: 413853
|
|
---
|
|
test/CMakeLists.txt | 9 ----
|
|
test/testsmart.cpp | 102 --------------------------------------------
|
|
2 files changed, 111 deletions(-)
|
|
delete mode 100644 test/testsmart.cpp
|
|
|
|
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
|
|
index 67f63a2..6a300d3 100644
|
|
--- a/test/CMakeLists.txt
|
|
+++ b/test/CMakeLists.txt
|
|
@@ -53,12 +53,3 @@ find_package (Threads)
|
|
# Execute external commands as root
|
|
kpm_test(testexternalcommand testexternalcommand.cpp)
|
|
add_test(NAME testexternalcommand COMMAND testexternalcommand ${BACKEND})
|
|
-
|
|
-# Including SMART files reference
|
|
-set(SMARTPARSER ${CMAKE_SOURCE_DIR}/src/core/smartdiskinformation.cpp
|
|
- ${CMAKE_SOURCE_DIR}/src/core/smartattributeparseddata.cpp
|
|
- ${CMAKE_SOURCE_DIR}/src/core/smartparser.cpp)
|
|
-
|
|
-# Test SMART support
|
|
-kpm_test(testsmart testsmart.cpp ${SMARTPARSER})
|
|
-add_test(NAME testsmart COMMAND testsmart ${BACKEND})
|
|
diff --git a/test/testsmart.cpp b/test/testsmart.cpp
|
|
deleted file mode 100644
|
|
index 2236af7..0000000
|
|
--- a/test/testsmart.cpp
|
|
+++ /dev/null
|
|
@@ -1,102 +0,0 @@
|
|
-#include "helpers.h"
|
|
-
|
|
-#include "util/externalcommand.h"
|
|
-#include "backend/corebackend.h"
|
|
-#include "backend/corebackendmanager.h"
|
|
-#include "core/smartstatus.h"
|
|
-#include "core/smartparser.h"
|
|
-
|
|
-#include <QCoreApplication>
|
|
-#include <QDebug>
|
|
-
|
|
-static QString getDefaultDevicePath();
|
|
-static bool testSmartStatus();
|
|
-static bool testSmartParser();
|
|
-
|
|
-int main(int argc, char **argv)
|
|
-{
|
|
- QCoreApplication app(argc, argv);
|
|
-
|
|
- KPMCoreInitializer i;
|
|
-
|
|
- if (argc == 2)
|
|
- i = KPMCoreInitializer(argv[1]);
|
|
-
|
|
- if (!i.isValid())
|
|
- return 1;
|
|
-
|
|
- CoreBackend *backend = CoreBackendManager::self()->backend();
|
|
-
|
|
- if (!backend)
|
|
- {
|
|
- qWarning() << "Couldn't get backend.";
|
|
- return 1;
|
|
- }
|
|
-
|
|
- if (!testSmartStatus() || !testSmartParser())
|
|
- return 1;
|
|
-
|
|
- return app.exec();
|
|
-}
|
|
-
|
|
-static QString getDefaultDevicePath()
|
|
-{
|
|
- // Getting default home partition using 'df -P /home | awk 'END{print $1}'' command
|
|
- ExternalCommand command(QStringLiteral("df"), { QStringLiteral("-P"), QStringLiteral("/home"), QStringLiteral("|"),
|
|
- QStringLiteral("awk"), QStringLiteral("\'END{print $1}\'") });
|
|
-
|
|
- if (command.run() && command.exitCode() == 0) {
|
|
- QString output = command.output();
|
|
- return output;
|
|
- }
|
|
-
|
|
- return QString();
|
|
-}
|
|
-
|
|
-static bool testSmartStatus()
|
|
-{
|
|
- QString devicePath = getDefaultDevicePath();
|
|
-
|
|
- SmartStatus smart(devicePath);
|
|
-
|
|
- if (smart.devicePath() != devicePath)
|
|
- return false;
|
|
-
|
|
- if (!smart.status())
|
|
- return false;
|
|
-
|
|
- if (smart.modelName() == QString())
|
|
- return false;
|
|
-
|
|
- if (smart.firmware() == QString())
|
|
- return false;
|
|
-
|
|
- if (smart.serial() == QString())
|
|
- return false;
|
|
-
|
|
- if (smart.selfTestStatus() != SmartStatus::SelfTestStatus::Success)
|
|
- return false;
|
|
-
|
|
- if (!smart.isValid())
|
|
- return false;
|
|
-
|
|
- return true;
|
|
-}
|
|
-
|
|
-static bool testSmartParser()
|
|
-{
|
|
- QString devicePath = getDefaultDevicePath();
|
|
-
|
|
- SmartParser parser(devicePath);
|
|
-
|
|
- if (!parser.init())
|
|
- return false;
|
|
-
|
|
- if (parser.devicePath() != devicePath)
|
|
- return false;
|
|
-
|
|
- if (!parser.diskInformation())
|
|
- return false;
|
|
-
|
|
- return true;
|
|
-}
|
|
--
|
|
2.17.1
|