mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
8830740643
* gnu/packages/patches/icecat-CVE-2015-0822.patch, gnu/packages/patches/icecat-CVE-2015-0827-pt-1.patch, gnu/packages/patches/icecat-CVE-2015-0827-pt-2.patch, gnu/packages/patches/icecat-CVE-2015-0827-pt-3.patch, gnu/packages/patches/icecat-CVE-2015-0831-pt-1.patch, gnu/packages/patches/icecat-CVE-2015-0831-pt-2.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-01.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-02.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-03.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-04.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-05.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-06.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-07.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-08.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-09.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-10.patch, gnu/packages/patches/icecat-CVE-2015-0836-pt-11.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
26 lines
844 B
Diff
26 lines
844 B
Diff
From 4106ffa6ee83b814428bb07948b3595e3fa3847e Mon Sep 17 00:00:00 2001
|
|
From: Jan de Mooij <jdemooij@mozilla.com>
|
|
Date: Tue, 10 Feb 2015 09:40:46 +0100
|
|
Subject: [PATCH] Bug 1128196 - Don't relazify scripts with a TypeScript.
|
|
r=till, a=lmandel
|
|
|
|
---
|
|
js/src/jsscript.h | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/js/src/jsscript.h b/js/src/jsscript.h
|
|
index 4d548ef..9a0cfbb 100644
|
|
--- a/js/src/jsscript.h
|
|
+++ b/js/src/jsscript.h
|
|
@@ -1251,7 +1251,7 @@ class JSScript : public js::gc::BarrieredCell<JSScript>
|
|
}
|
|
|
|
bool isRelazifiable() const {
|
|
- return (selfHosted() || lazyScript) &&
|
|
+ return (selfHosted() || lazyScript) && !types &&
|
|
!isGenerator() && !hasBaselineScript() && !hasAnyIonScript() && !hasBeenInlined();
|
|
}
|
|
void setLazyScript(js::LazyScript *lazy) {
|
|
--
|
|
2.2.1
|
|
|