mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
6457985e39
* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Renamed file. * gnu/packages/patches/abseil-cpp-fix-strerror_test.patch: New file. * gnu/local.mk (dist_patch_DATA): Rename / add files. * gnu/packages/cpp.scm (abseil-cpp)[source]: Use files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
16 lines
570 B
Diff
16 lines
570 B
Diff
The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
|
|
in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
|
|
a googletest release.
|
|
|
|
--- a/absl/container/internal/unordered_map_modifiers_test.h
|
|
+++ b/absl/container/internal/unordered_map_modifiers_test.h
|
|
@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
|
|
}
|
|
};
|
|
|
|
+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
|
|
GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
|
|
+#endif
|
|
|
|
TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
|
|
|