guix/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
Greg Hogan ef0c65969b
gnu: aws-sdk-cpp: Update to 1.9.92.
* gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch,
gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch,
gnu/packages/patches/aws-sdk-cpp-disable-werror.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/cpp.scm (aws-sdk-cpp): Update to 1.9.92.
[source]: Use patches.
[inputs, propagated-inputs]: Update AWS dependencies to Common Runtime.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2021-10-16 00:01:59 +02:00

44 lines
1.9 KiB
Diff

--- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
+++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
makeRandomHttpRequest(httpClient, false);
}
-TEST(HttpClientTest, TestRandomURLWithProxy)
-{
- ClientConfiguration configuration = makeClientConfigurationWithProxy();
- auto httpClient = CreateHttpClient(configuration);
- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
-}
+//TEST(HttpClientTest, TestRandomURLWithProxy)
+//{
+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
+// auto httpClient = CreateHttpClient(configuration);
+// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
+//}
TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
{
@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
makeRandomHttpRequest(httpClient, false);
}
-TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
-{
- ClientConfiguration configuration = makeClientConfigurationWithProxy();
- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
- auto httpClient = CreateHttpClient(configuration);
- makeRandomHttpRequest(httpClient, true);
-}
+//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
+//{
+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
+// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
+// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
+// auto httpClient = CreateHttpClient(configuration);
+// makeRandomHttpRequest(httpClient, true);
+//}
// TODO: Pending Fix on Windows.
#if ENABLE_CURL_CLIENT