mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2025-01-03 18:09:18 -05:00
29a780147d
* gnu/packages/patches/icecat-CVE-2016-1930-pt01.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt02.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt03.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt04.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt05.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt06.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt07.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt08.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt09.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt10.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt11.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt12.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt13.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt14.patch, gnu/packages/patches/icecat-CVE-2016-1930-pt15.patch, gnu/packages/patches/icecat-CVE-2016-1935.patch, gnu/packages/patches/icecat-bug-1146335-pt1.patch, gnu/packages/patches/icecat-bug-1146335-pt2.patch, gnu/packages/patches/icecat-limit-max-buffers-size-for-ANGLE.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
33 lines
1.3 KiB
Diff
33 lines
1.3 KiB
Diff
Copied from: https://hg.mozilla.org/releases/mozilla-esr38/rev/debff255c08e
|
|
Security advisory: https://www.mozilla.org/en-US/security/advisories/mfsa2016-01/
|
|
Mozilla Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1234571
|
|
|
|
# HG changeset patch
|
|
# User Randell Jesup <rjesup@jesup.org>
|
|
# Date 1451928471 18000
|
|
# Node ID debff255c08e898be370e307e1e014f5601c20c6
|
|
# Parent f31d643afd4159b5422ae5aebcbbea0a088e018e
|
|
Bug 1234571 - unregister encoded-frame callback when releasing codec databases. r=pkerr, a=al
|
|
|
|
diff --git a/media/webrtc/trunk/webrtc/modules/video_coding/main/source/generic_encoder.cc b/media/webrtc/trunk/webrtc/modules/video_coding/main/source/generic_encoder.cc
|
|
--- a/media/webrtc/trunk/webrtc/modules/video_coding/main/source/generic_encoder.cc
|
|
+++ b/media/webrtc/trunk/webrtc/modules/video_coding/main/source/generic_encoder.cc
|
|
@@ -71,16 +71,17 @@ VCMGenericEncoder::VCMGenericEncoder(Vid
|
|
VCMGenericEncoder::~VCMGenericEncoder()
|
|
{
|
|
}
|
|
|
|
int32_t VCMGenericEncoder::Release()
|
|
{
|
|
_bitRate = 0;
|
|
_frameRate = 0;
|
|
+ _encoder.RegisterEncodeCompleteCallback(NULL);
|
|
_VCMencodedFrameCallback = NULL;
|
|
return _encoder.Release();
|
|
}
|
|
|
|
int32_t
|
|
VCMGenericEncoder::InitEncode(const VideoCodec* settings,
|
|
int32_t numberOfCores,
|
|
uint32_t maxPayloadSize)
|
|
|