mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 15:22:18 -05:00
c463d7ac91
* gnu/packages/java.scm (openjdk10)[source](patches): Add two patches. [source](snippet): While here, simplify. * gnu/packages/patches/openjdk-10-hotspot-pointer-comparison.patch, gnu/packages/patches/openjdk-10-hotspot-stack-size.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
28 lines
936 B
Diff
28 lines
936 B
Diff
Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
|
|
|
|
Backported from:
|
|
|
|
https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
|
|
|
|
diff --git a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
|
|
--- a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
|
|
+++ b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
|
|
@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
|
|
longjmp(context, 1);
|
|
}
|
|
|
|
+static char* altstack = NULL;
|
|
+
|
|
void set_signal_handler() {
|
|
- static char altstack[SIGSTKSZ];
|
|
+ if (altstack == NULL) {
|
|
+ // Dynamically allocated in case SIGSTKSZ is not constant
|
|
+ altstack = malloc(SIGSTKSZ);
|
|
+ if (altstack == NULL) {
|
|
+ fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
|
|
+ exit(7);
|
|
+ }
|
|
+ }
|
|
|
|
stack_t ss = {
|
|
.ss_size = SIGSTKSZ,
|