mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-20 05:37:34 -05:00
1e96e6ac8b
* gnu/packages/julia.scm (libuv-julia): Upgrade to 2.0.0-1.35b1504. (libunwind-julia): New variable. (llvm-patch): Rename to ... (julia-patch): ... this. Update to 1.3.1. (llvm-julia): Adjust patch-set based on above change. Adjust indent. (julia): Update to 1.3.1. [source]: Add patch. [arguments]: Adjust custom 'prepare-deps (llvm-patch): Rename to ... (julia-patch): ... this. Update to 1.3.1. (llvm-julia): Adjust patch-set based on above change. (julia): Upgrade to 1.3.1. [arguments]: Adjust custom 'prepare-deps phase based on changed inputs. Remove most of 'hardcode-soname-map. Adjust 'fix-include-and-link-paths. Add new 'fix-precompile phase. Adjust custom 'disable-broken-tests phase. Add new 'make-wrapper phase. Adjust make-flags. [inputs]: Add p7zip, mbedtls-apache, curl libssh2. Remove openspecfun, fftw, fftwf, python2-virtualenv, rmath. Replace libunwind with libunwind-julia, custom suitesparse with system suitesparse, custom dsfmt with system dsfmt. [native-search-paths]: Add JULIA_DEPOT_PATH. * gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
28 lines
785 B
Diff
28 lines
785 B
Diff
--- /dev/null
|
|
+++ b/gnu/packages/patches/julia-SOURCE_DATE_EPOCH-mtime.patch
|
|
@@ -0,0 +1,22 @@
|
|
+Fix one of upstream non-determinism, tracked here:
|
|
+
|
|
+https://github.com/JuliaLang/julia/issues/34115
|
|
+https://github.com/JuliaLang/julia/issues/25900
|
|
+
|
|
+
|
|
+Patch by Nicoló Balzarotti <nicolo@nixo.xyz>.
|
|
+
|
|
+--- a/base/loading.jl
|
|
++++ b/base/loading.jl
|
|
+@@ -807,7 +807,10 @@
|
|
+ path = normpath(joinpath(dirname(prev), _path))
|
|
+ end
|
|
+ if _track_dependencies[]
|
|
+- push!(_require_dependencies, (mod, path, mtime(path)))
|
|
++ push!(_require_dependencies,
|
|
++ (mod, path,
|
|
++ haskey(ENV, "SOURCE_DATE_EPOCH") ?
|
|
++ parse(Float64, ENV["SOURCE_DATE_EPOCH"]) : mtime(path)))
|
|
+ end
|
|
+ return path, prev
|
|
+ end
|
|
--
|
|
2.26.0
|
|
|