mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-18 04:37:36 -05:00
1155a88308
* gnu/packages/patches/ungoogled-chromium-system-opus.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%preserved-third-party-files): Adjust for 89. (%chromium-version): Remove variable. (%ungoogled-revision): Set to 89.0.4389.90-1. (%ungoogled-origin): Conditionally set file name based on commit/tag. (%guix-patches): Add the new file. (libvpx/chromium): Update to 1.9.0-104-gb5d77a48d. (ungoogled-chromium)[version]: Use %UNGOOGLED-REVISION. [source]: Update hash. [arguments]: Adjust #:configure-flags for build system changes. Don't build with external WebRTC SSL library. Remove obsolete substitution. [inputs]: Remove OPENSSL. Change from PIPEWIRE to PIPEWIRE-0.3.
27 lines
1 KiB
Diff
27 lines
1 KiB
Diff
Add missing build dependency on Opus so that system headers are found.
|
|
|
|
Taken from upstream:
|
|
https://chromium-review.googlesource.com/c/chromium/src/+/2644623
|
|
|
|
diff --git a/third_party/blink/renderer/modules/webcodecs/BUILD.gn b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
--- a/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
+++ b/third_party/blink/renderer/modules/webcodecs/BUILD.gn
|
|
@@ -65,6 +65,7 @@ blink_modules_sources("webcodecs") {
|
|
"//media/mojo/clients",
|
|
"//media/mojo/mojom",
|
|
"//third_party/libyuv:libyuv",
|
|
+ "//third_party/opus",
|
|
]
|
|
if (media_use_openh264) {
|
|
deps += [ "//third_party/openh264:encoder" ]
|
|
diff --git a/third_party/blink/renderer/modules/webcodecs/DEPS b/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
--- a/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
+++ b/third_party/blink/renderer/modules/webcodecs/DEPS
|
|
@@ -19,6 +19,7 @@ include_rules = [
|
|
|
|
"+third_party/libyuv",
|
|
"+third_party/openh264",
|
|
+ "+third_party/opus",
|
|
|
|
"+ui/gfx/color_space.h",
|
|
"+ui/gfx/geometry/rect.h",
|