mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-19 21:27:37 -05:00
a4c04bee7b
* gnu/packages/patches/boost-dumpversion.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/boost.scm (boost)[source]: Apply it, [native-inputs]: add python unless cross-compiling, [arguments]: pass cross-compilation mandatory flags and fill a user-config.jam file pointing to cross-compiler. Disable python support that is broken when cross-compiling. Disable provide-libboost_python when cross-compiling.
24 lines
800 B
Diff
24 lines
800 B
Diff
This issue is described here: https://github.com/openwrt/packages/pull/8685
|
|
and has not been solved as of 1.70.0 release.
|
|
|
|
--- a/tools/build/src/tools/common.jam
|
|
+++ b/tools/build/src/tools/common.jam
|
|
@@ -973,18 +973,6 @@
|
|
}
|
|
}
|
|
|
|
- # From GCC 5, versioning changes and minor becomes patch
|
|
- if $(tag) = gcc && [ numbers.less 4 $(version[1]) ]
|
|
- {
|
|
- version = $(version[1]) ;
|
|
- }
|
|
-
|
|
- # Ditto, from Clang 4
|
|
- if ( $(tag) = clang || $(tag) = clangw ) && [ numbers.less 3 $(version[1]) ]
|
|
- {
|
|
- version = $(version[1]) ;
|
|
- }
|
|
-
|
|
# On intel, version is not added, because it does not matter and it is the
|
|
# version of vc used as backend that matters. Ideally, we should encode the
|
|
# backend version but that would break compatibility with V1.
|