mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
4a82b3f92e
The binaries for dblatex aren't provided by texlive-updmap.cfg but by texlive-bin. * gnu/packages/patches/dblatex-inkscape-1.0.patch: New file. * gnu/local.mk: Register it. * gnu/packages/docbook.scm (dblatex)[source]: Use dblatex-inkscape-1.0.patch. [arguments]<#:tests?>: Enable tests. <#:phases>: Rename 'set-path to 'wrap-dblatex. Wrap with texlive-bin rather than texlive-updmap.cfg in PATH and wrap GUIX_TEXMF in 'wrap-dblatex. Add 'check-wrap phase. [native-inputs]: Add docbook-mathml-1.0. [inputs]: Restyle. Add texlive-bin. Replace inkscape/stable with inkscape. Within texlive-updmap.cfg add previously missing: texlive-amsmath, texlive-auxhook, texlive-bigintcalc, texlive-bin, texlive-bitset, texlive-bookmark, texlive-colortbl, texlive-courier, texlive-eepic, texlive-epstopdf-pkg, texlive-eso-pic, texlive-etexcmds, texlive-fancyhdr, texlive-gettitlestring, texlive-graphics, texlive-graphics-cfg, texlive-helvetic, texlive-hycolor, texlive-hyperref, texlive-infwarerr, texlive-intcalc, texlive-kpathsea, texlive-kvdefinekeys, texlive-kvoptions, texlive-kvsetkeys, texlive-l3backend, texlive-latex, texlive-latex-bin, texlive-letltxmacro, texlive-ltxcmds, texlive-pdfescape, texlive-pdflscape, texlive-pdftexcmds, texlive-psnfss, texlive-rerunfilecheck, texlive-symbol, texlive-times, texlive-tools, texlive-uniquecounter, texlive-url and texlive-zapfding. Add fig2dev. (dblatex/stable)[inputs]: Replace inkscape with inkscape/stable. Co-authored-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I4fb2e1f894b98a4e33a0438a1dda569eeb9eae81
39 lines
1.5 KiB
Diff
39 lines
1.5 KiB
Diff
# Imported from <https://sourceforge.net/p/dblatex/dblatex/merge-requests/4/>
|
|
|
|
# HG changeset patch
|
|
# User Jan Tojnar <jtojnar@gmail.com>
|
|
# Date 1588714251 -7200
|
|
# Tue May 05 23:30:51 2020 +0200
|
|
# Branch inkscape1
|
|
# Node ID 611cc4a4a878d57f5877f2d418864560f68d25cf
|
|
# Parent 3ddf5d6cedcbc9c8b98c4da77fd545b2478d90a3
|
|
Port to Inkscape 1.0
|
|
|
|
Inkscape revamped the CLI flags:
|
|
|
|
https://gitlab.com/inkscape/inbox/issues/2416
|
|
|
|
diff -r 3ddf5d6cedcb -r 611cc4a4a878 docs/custom/dblatex.xconf
|
|
--- a/docs/custom/dblatex.xconf Tue Sep 10 00:40:26 2019 +0200
|
|
+++ b/docs/custom/dblatex.xconf Tue May 05 23:30:51 2020 +0200
|
|
@@ -18,7 +18,7 @@
|
|
<imagedata>
|
|
<converter src="svg" dst="*" docformat="pdf">
|
|
<command>
|
|
- inkscape -z -D --export-dpi=600 --export-%(dst)s=%(output)s %(input)s
|
|
+ inkscape -D --export-dpi=600 --export-type=%(dst)s --export-filename=%(output)s %(input)s
|
|
</command>
|
|
</converter>
|
|
</imagedata>
|
|
diff -r 3ddf5d6cedcb -r 611cc4a4a878 lib/dbtexmf/core/imagedata.py
|
|
--- a/lib/dbtexmf/core/imagedata.py Tue Sep 10 00:40:26 2019 +0200
|
|
+++ b/lib/dbtexmf/core/imagedata.py Tue May 05 23:30:51 2020 +0200
|
|
@@ -178,7 +178,7 @@
|
|
class SvgConverter(ImageConverter):
|
|
def __init__(self, imgsrc, imgdst="", docformat="", backend=""):
|
|
ImageConverter.__init__(self, imgsrc="svg", imgdst=imgdst)
|
|
- self.add_command(["inkscape", "-z", "-D", "--export-%(dst)s=%(output)s",
|
|
+ self.add_command(["inkscape", "-D", "--export-type=%(dst)s", "--export-filename=%(output)s",
|
|
"%(input)s"])
|
|
|
|
|