mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 23:46:13 -05:00
d7e7494bc4
* gnu/packages/admin.scm (fail2ban): New variable. * gnu/packages/patches/fail2ban-0.11.2_CVE-2021-32749.patch, gnu/packages/patches/fail2ban-0.11.2_fix-setuptools-drop-2to3.patch, gnu/packages/patches/fail2ban-0.11.2_fix-test-suite.patch, gnu/packages/patches/fail2ban-paths-guix-conf.patch, gnu/packages/patches/fail2ban-python310-server-action.patch, gnu/packages/patches/fail2ban-python310-server-actions.patch, gnu/packages/patches/fail2ban-python310-server-jails.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
25 lines
711 B
Diff
25 lines
711 B
Diff
From 42dee38ad2ac5c3f23bdf297d824022923270dd9 Mon Sep 17 00:00:00 2001
|
|
From: "Sergey G. Brester" <serg.brester@sebres.de>
|
|
Date: Mon, 8 Feb 2021 17:25:45 +0100
|
|
Subject: [PATCH] amend for `Mapping`
|
|
|
|
---
|
|
fail2ban/server/actions.py | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/fail2ban/server/actions.py b/fail2ban/server/actions.py
|
|
index b7b95b445a..897d907c1a 100644
|
|
--- a/fail2ban/server/actions.py
|
|
+++ b/fail2ban/server/actions.py
|
|
@@ -28,7 +28,10 @@
|
|
import os
|
|
import sys
|
|
import time
|
|
-from collections import Mapping
|
|
+try:
|
|
+ from collections.abc import Mapping
|
|
+except ImportError:
|
|
+ from collections import Mapping
|
|
try:
|
|
from collections import OrderedDict
|
|
except ImportError:
|