mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
b208f71b9b
* gnu/packages/python.scm (python-genshi, python2-genshi): New variables. * gnu/packages/patches/python-genshi-add-support-for-python-3.4-AST.patch: New file. * gnu/packages/patches/python-genshi-buildable-on-python-2.7.patch: New file. * gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch: New file. * gnu/packages/patches/python-genshi-fix-tests-on-python-3.5.patch: New file. * gnu/packages/patches/python-genshi-isstring-helper.patch: New file. * gnu/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch: New file. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
32 lines
986 B
Diff
32 lines
986 B
Diff
From cef2c8df44166195e1705638f9f17033a4943bb7 Mon Sep 17 00:00:00 2001
|
|
From: Simon Cross <hodgestar@gmail.com>
|
|
Date: Sun, 16 Feb 2014 18:32:21 +0000
|
|
Subject: [PATCH 02/15] Disable the speedups C extension on CPython >= 3.3
|
|
since Genshi doesn't support the new Unicode C API yet.
|
|
|
|
---
|
|
setup.py | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 123a2cb..a3d748c 100755
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -65,9 +65,13 @@ available.""")
|
|
|
|
|
|
if Feature:
|
|
+ # Optional C extension module for speeding up Genshi:
|
|
+ # Not activated by default on:
|
|
+ # - PyPy (where it harms performance)
|
|
+ # - CPython >= 3.3 (the new Unicode C API is not supported yet)
|
|
speedups = Feature(
|
|
"optional C speed-enhancements",
|
|
- standard = not is_pypy,
|
|
+ standard = not is_pypy and sys.version_info < (3, 3),
|
|
ext_modules = [
|
|
Extension('genshi._speedups', ['genshi/_speedups.c']),
|
|
],
|
|
--
|
|
2.12.0
|
|
|