mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
67c30ff8ad
All packages updated at the same time as they have a shared version. rocclr is no longer a stand-alone package, so the previous version is kept as rocclr-4 and the current version is just the source, rocclr-src, needed by rocm-opencl-runtime. * gnu/packages/patches/rocm-opencl-runtime-3.10.0-includes.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-nocltrace.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/rocm-comgr-3.1.0-dependencies.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noclinfo.patch, gnu/packages/patches/rocm-opencl-runtime-4.3-noopencl.patch: Update patches. * gnu/packages/rocm.scm (rocm-cmake, rocm-device-libs, rocm-comgr, roct-thunk-interface, rocr-runtime, rocm-opencl-runtime, rocminfo, rocm-bandwidth-test): Update to 5.1.3. (roct-thunk-interface)[inputs]: Add libdrm. [native-inputs]: Add gcc:lib and pkg-config. (rocclr-src): New variable. (rocclr-4): New variable (previous version of the package). (rocm-opencl-runtime)[source]: Remove obsolete patches. [arguments]: Rewrite with gexps. Add needed #:configure-flags. [inputs]: Remove rocclr, add numactl. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
Do not build and install clinfo.
|
|
|
|
diff --git a/CMakeLists.txt.orig b/CMakeLists.txt
|
|
index 76847d3..3f62bfe 100644
|
|
--- a/CMakeLists.txt.orig
|
|
+++ b/CMakeLists.txt
|
|
@@ -15,9 +15,9 @@ option(FILE_REORG_BACKWARD_COMPATIBILITY "Enable File Reorganization backward co
|
|
|
|
|
|
set(OPENCL_ICD_LOADER_HEADERS_DIR "${CMAKE_CURRENT_LIST_DIR}/khronos/headers/opencl2.2" CACHE PATH "")
|
|
#add_subdirectory(khronos/icd)
|
|
add_subdirectory(amdocl)
|
|
-add_subdirectory(tools/clinfo)
|
|
+#add_subdirectory(tools/clinfo)
|
|
add_subdirectory(tools/cltrace)
|
|
if(BUILD_TESTS)
|
|
add_subdirectory(tests/ocltst)
|
|
diff --git a/packaging/CMakeLists.txt b/packaging/CMakeLists.txt
|
|
index 48353eb..cd1e7c1 100644
|
|
--- a/packaging/CMakeLists.txt
|
|
+++ b/packaging/CMakeLists.txt
|
|
@@ -5,6 +5,6 @@ set(CPACK_COMPONENTS_ALL binary dev icd)
|
|
set(CPACK_DEB_COMPONENT_INSTALL ON)
|
|
set(CPACK_RPM_COMPONENT_INSTALL ON)
|
|
|
|
-install(TARGETS clinfo DESTINATION bin COMPONENT binary)
|
|
+#install(TARGETS clinfo DESTINATION bin COMPONENT binary)
|
|
install(TARGETS amdocl DESTINATION lib COMPONENT binary)
|
|
install(FILES ${CMAKE_SOURCE_DIR}/LICENSE.txt DESTINATION share/doc/${CMAKE_PROJECT_NAME} COMPONENT binary)
|