mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
098f2eea33
* gnu/packages/chromium.scm (%preserved-third-party-files): Include bundled Vulkan headers. (%chromium-version): Set to 101.0.4951.41. (%debian-revision): Set to debian/101.0.4951.41-2. (%debian-patches): Add one new patch. (%ungoogled-origin, ungoogled-chromium): Update hashes. * gnu/packages/patches/ungoogled-chromium-system-nspr.patch: Refresh.
54 lines
1.8 KiB
Diff
54 lines
1.8 KiB
Diff
Build with the system NSPR library instead of the bundled version.
|
|
|
|
Originally based on this Debian patch:
|
|
https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/system/nspr.patch
|
|
|
|
diff --git a/base/BUILD.gn b/base/BUILD.gn
|
|
--- a/base/BUILD.gn
|
|
+++ b/base/BUILD.gn
|
|
@@ -184,6 +184,12 @@ buildflag_header("ios_cronet_buildflags") {
|
|
flags = [ "CRONET_BUILD=$is_cronet_build" ]
|
|
}
|
|
|
|
+if (is_linux) {
|
|
+ ldflags = [
|
|
+ "-lnspr4",
|
|
+ ]
|
|
+}
|
|
+
|
|
# Base and everything it depends on should be a static library rather than
|
|
# a source set. Base is more of a "library" in the classic sense in that many
|
|
# small parts of it are used in many different contexts. This combined with a
|
|
@@ -838,8 +844,6 @@ mixed_component("base") {
|
|
"third_party/cityhash_v103/src/city_v103.cc",
|
|
"third_party/cityhash_v103/src/city_v103.h",
|
|
"third_party/icu/icu_utf.h",
|
|
- "third_party/nspr/prtime.cc",
|
|
- "third_party/nspr/prtime.h",
|
|
"third_party/superfasthash/superfasthash.c",
|
|
"thread_annotations.h",
|
|
"threading/hang_watcher.cc",
|
|
diff --git a/base/time/pr_time_unittest.cc b/base/time/pr_time_unittest.cc
|
|
--- a/base/time/pr_time_unittest.cc
|
|
+++ b/base/time/pr_time_unittest.cc
|
|
@@ -6,7 +6,7 @@
|
|
#include <time.h>
|
|
|
|
#include "base/compiler_specific.h"
|
|
-#include "base/third_party/nspr/prtime.h"
|
|
+#include <nspr/prtime.h>
|
|
#include "base/time/time.h"
|
|
#include "build/build_config.h"
|
|
#include "testing/gtest/include/gtest/gtest.h"
|
|
diff --git a/base/time/time.cc b/base/time/time.cc
|
|
--- a/base/time/time.cc
|
|
+++ b/base/time/time.cc
|
|
@@ -21,7 +21,7 @@
|
|
#include <utility>
|
|
|
|
#include "base/strings/stringprintf.h"
|
|
-#include "base/third_party/nspr/prtime.h"
|
|
+#include <nspr/prtime.h>
|
|
#include "base/time/time_override.h"
|
|
#include "build/build_config.h"
|
|
#include "third_party/abseil-cpp/absl/types/optional.h"
|