mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-07 15:36:20 -05:00
51443772b8
* gnu/packages/python-xyz.scm (python-argcomplete)[version]: Update to 1.11.1. [arguments]: Remove, obsolete. [inputs]: Remove as well. * gnu/packages/patches/python-argcomplete-1.11.1-fish31.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
29 lines
1 KiB
Diff
29 lines
1 KiB
Diff
Upstream commit fixing testcases for fish>=3.1, see
|
|
https://github.com/kislyuk/argcomplete/commit/08bfc8a788e8081515d733e67be026d051c726f7
|
|
|
|
diff --git a/test/test.py b/test/test.py
|
|
index e91352b..2c34806 100755
|
|
--- a/test/test.py
|
|
+++ b/test/test.py
|
|
@@ -28,6 +28,8 @@
|
|
|
|
BASH_VERSION = subprocess.check_output(['bash', '-c', 'echo $BASH_VERSION']).decode()
|
|
BASH_MAJOR_VERSION = int(BASH_VERSION.split('.')[0])
|
|
+FISH_VERSION_STR = subprocess.check_output(['fish', '-c', 'echo -n $FISH_VERSION']).decode()
|
|
+FISH_VERSION_TUPLE = tuple(int(x) for x in FISH_VERSION_STR.split('.'))
|
|
|
|
|
|
class TempDir(object):
|
|
@@ -1258,8 +1260,11 @@ class TestFish(_TestSh, unittest.TestCase):
|
|
expected_failures = [
|
|
'test_parse_special_characters',
|
|
'test_comp_point',
|
|
- 'test_special_characters_double_quoted'
|
|
]
|
|
+ if FISH_VERSION_TUPLE < (3, 1):
|
|
+ expected_failures.extend([
|
|
+ 'test_special_characters_double_quoted'
|
|
+ ])
|
|
|
|
skipped = [
|
|
'test_single_quotes_in_single_quotes',
|