guix/gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch
Maxim Cournoyer 64e1797e21
gnu: jami: Update to 20240325.0.
* gnu/packages/jami.scm
(libjami): Update to 20240325.0.
[make-flags]: Reinstate ut_media_player test.
[phases]: Remove obsolete extend-scheduler-test-timeout phase.
(jami): Update to 20240325.0.
[source]: Remove jami-qml-tests-discovery patch.  Add jami-qwindowkit and
jami-tests-qtwebengine-ifdef-to-if patches.
[configure-flags]: Add -DFETCHCONTENT_TRY_FIND_PACKAGE_MODE=ALWAYS.
Replace -DENABLE_TESTS=ON with -DBUILD_TESTING=ON.
[phases] <check>: Update comment for QML test suite.
[native-inputs]: Add qthttpserver and qtwebsockets.
[inputs]: Add qwindowkit.
* gnu/packages/patches/jami-qml-tests-discovery.patch: Delete file.
* gnu/packages/patches/jami-unbundle-dependencies.patch: Update patch.
* gnu/packages/patches/jami-qwindowkit.patch: New file.
* gnu/packages/patches/jami-tests-qtwebengine-ifdef-to-if.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): Update accordingly.

Change-Id: I5d47bdfd2aabab5baff44db8436051a9890cba6d
2024-04-03 18:05:12 -04:00

26 lines
769 B
Diff

Upstream-status: https://lists.gnu.org/archive/html/jami/2024-03/msg00005.html
Fix macro value checking.
diff --git a/tests/qml/main.cpp b/tests/qml/main.cpp
index 2fbecebe..8cb3de69 100644
--- a/tests/qml/main.cpp
+++ b/tests/qml/main.cpp
@@ -35,7 +35,7 @@
#include <QtQuickTest/quicktest.h>
#include <QSignalSpy>
-#ifdef WITH_WEBENGINE
+#if WITH_WEBENGINE
#include <QtWebEngineCore>
#include <QtWebEngineQuick>
#endif
@@ -192,7 +192,7 @@ main(int argc, char** argv)
// Allow the user to enable fatal warnings for certain tests.
Utils::remove_argument(argv, argc, "--failonwarn", [&]() { qputenv("QT_FATAL_WARNINGS", "1"); });
-#ifdef WITH_WEBENGINE
+#if WITH_WEBENGINE
QtWebEngineQuick::initialize();
#endif
QTEST_SET_MAIN_SOURCE_PATH