mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-25 22:08:16 -05:00
b4148713d1
Keep the older version as wlroots-0.16 since a few packages break without it. * gnu/packages/wm.scm (wlroots): Update to 0.17.1. [source]: Add patch. [propagated-inputs]: Add libdisplay-info. * gnu/packages/patches/wlroots-hwdata-fallback.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/wm.scm (wlroots-0.16): New variable. * gnu/packages/wm.scm (cage)[inputs]: Replace wlroots with wlroots-0.16. * gnu/packages/wm.scm (fnott)[inputs]: Likewise. * gnu/packages/wm.scm (dwl)[inputs]: Likewise. * gnu/packages/wm.scm (sway)[inputs]: Likewise. * gnu/packages/wm.scm (cagebreak)[inputs]: Likewise. * gnu/packages/wm.scm (hikari)[inputs]: Likewise. * gnu/packages/wm.scm (river)[native-inputs]: Likewise. Change-Id: Ib3d3938d6486fb1674380811a6dc0a512c991ac7 Signed-off-by: John Kehayias <john.kehayias@protonmail.com>
46 lines
1.2 KiB
Diff
46 lines
1.2 KiB
Diff
backend/drm: add hardcoded hwdata path fallback
|
|
|
|
Add hardcoded fallback "/usr/share/hwdata/pnp.ids" as a
|
|
temporary solution to get things working in Guix until
|
|
hwdata ships with pkg-config file.
|
|
|
|
diff --git a/backend/drm/meson.build b/backend/drm/meson.build
|
|
index 6fcb2c15..ed95360a 100644
|
|
--- a/backend/drm/meson.build
|
|
+++ b/backend/drm/meson.build
|
|
@@ -1,8 +1,7 @@
|
|
hwdata = dependency(
|
|
'hwdata',
|
|
- required: 'drm' in backends,
|
|
+ required: false,
|
|
native: true,
|
|
- not_found_message: 'Required for the DRM backend.',
|
|
)
|
|
|
|
libdisplay_info = dependency(
|
|
@@ -19,15 +18,21 @@ libliftoff = dependency(
|
|
required: false,
|
|
)
|
|
|
|
-if not (hwdata.found() and libdisplay_info.found() and features['session'])
|
|
+if hwdata.found()
|
|
+ hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
|
|
+ pnp_ids = files(hwdata_dir / 'pnp.ids')
|
|
+else
|
|
+ pnp_ids = files('/usr/share/hwdata/pnp.ids')
|
|
+endif
|
|
+
|
|
+if not (libdisplay_info.found() and features['session'])
|
|
subdir_done()
|
|
endif
|
|
|
|
-hwdata_dir = hwdata.get_variable(pkgconfig: 'pkgdatadir')
|
|
pnpids_c = custom_target(
|
|
'pnpids.c',
|
|
output: 'pnpids.c',
|
|
- input: files(hwdata_dir / 'pnp.ids'),
|
|
+ input: pnp_ids,
|
|
feed: true,
|
|
capture: true,
|
|
command: files('gen_pnpids.sh'),
|
|
|