mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-15 11:25:22 -05:00
a8e149434e
Patches should fix all CVEs reported by `guix lint`: CVE-2015-7747; CVE-2017-6827, CVE-2017-6828, CVE-2017-6829, CVE-2017-6830, CVE-2017-6831, CVE-2017-6832, CVE-2017-6833, CVE-2017-6834, CVE-2017-6835, CVE-2017-6836, CVE-2017-6837, CVE-2017-6838, CVE-2017-6839; CVE-2018-13440; CVE-2018-17095 Since the patches do not reference to CVEs, it's a bit hard to tell which patch actually closes which CVE. Debian reports all these to be closed by the patches below and NixPkgs provides references. * gnu/packages/audio.scm (audiofile): New variable. * gnu/packages/patches/audiofile-fix-datatypes-in-tests.patch, gnu/packages/patches/audiofile-fix-sign-conversion.patch, gnu/packages/patches/audiofile-CVE-2015-7747.patch, gnu/packages/patches/audiofile-CVE-2018-13440.patch, gnu/packages/patches/audiofile-CVE-2018-17095.patch, gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch, gnu/packages/patches/audiofile-Fail-on-error-in-parseFormat.patch, gnu/packages/patches/audiofile-Fix-index-overflow-in-IMA.cpp.patch, gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch, gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch, gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch, gnu/packages/patches/audiofile-hurd.patch, gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: New files. * gnu/local.mk: Add them.
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From: Antonio Larrosa <larrosa@kde.org>
|
|
Date: Mon, 6 Mar 2017 18:02:31 +0100
|
|
Subject: clamp index values to fix index overflow in IMA.cpp
|
|
|
|
This fixes #33
|
|
(also reported at https://bugzilla.opensuse.org/show_bug.cgi?id=1026981
|
|
and https://blogs.gentoo.org/ago/2017/02/20/audiofile-global-buffer-overflow-in-decodesample-ima-cpp/)
|
|
---
|
|
libaudiofile/modules/IMA.cpp | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/libaudiofile/modules/IMA.cpp b/libaudiofile/modules/IMA.cpp
|
|
index 7476d44..df4aad6 100644
|
|
--- a/libaudiofile/modules/IMA.cpp
|
|
+++ b/libaudiofile/modules/IMA.cpp
|
|
@@ -169,7 +169,7 @@ int IMA::decodeBlockWAVE(const uint8_t *encoded, int16_t *decoded)
|
|
if (encoded[1] & 0x80)
|
|
m_adpcmState[c].previousValue -= 0x10000;
|
|
|
|
- m_adpcmState[c].index = encoded[2];
|
|
+ m_adpcmState[c].index = clamp(encoded[2], 0, 88);
|
|
|
|
*decoded++ = m_adpcmState[c].previousValue;
|
|
|
|
@@ -210,7 +210,7 @@ int IMA::decodeBlockQT(const uint8_t *encoded, int16_t *decoded)
|
|
predictor -= 0x10000;
|
|
|
|
state.previousValue = clamp(predictor, MIN_INT16, MAX_INT16);
|
|
- state.index = encoded[1] & 0x7f;
|
|
+ state.index = clamp(encoded[1] & 0x7f, 0, 88);
|
|
encoded += 2;
|
|
|
|
for (int n=0; n<m_framesPerPacket; n+=2)
|