mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-16 19:57:39 -05:00
a3d6e1f432
* gnu/packages/perl.scm: Update to 5.24.0. [source]: Add and remove patches. * gnu/packages/patches/perl-reproducible-build-date.patch: New file. * gnu/packages/patches/perl-CVE-2015-8607.patch, gnu/packages/patches/perl-CVE-2016-2381.patch, gnu/packages/patches/perl-no-build-time.patch, gnu/packages/patches/perl-source-date-epoch.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Add and remove patches.
17 lines
489 B
Diff
17 lines
489 B
Diff
Don't encode the current timestamp.
|
|
|
|
This affects the output of `perl -V`, specifically the message "Compiled
|
|
at [...]".
|
|
|
|
diff --git a/perl.c b/perl.c
|
|
index 228a0d8..ed38313 100644
|
|
--- a/perl.c
|
|
+++ b/perl.c
|
|
@@ -1825,6 +1825,7 @@ S_Internals_V(pTHX_ CV *cv)
|
|
PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options,
|
|
sizeof(non_bincompat_options) - 1, SVs_TEMP));
|
|
|
|
+#define PERL_BUILD_DATE "Jan 1 1970 00:00:00"
|
|
#ifndef PERL_BUILD_DATE
|
|
# ifdef __DATE__
|
|
# ifdef __TIME__
|