guix/gnu/packages/patches/onnx-skip-model-downloads.patch
David Elsing 595cc594b6
gnu: onnx: Update to 1.16.2.
* gnu/packages/machine-learning.scm (onnx): Update to 1.16.2.
[source]: Remove patch.
[build-system]: Move to pyproject-build-system.
[arguments]<#:tests?>: Disable for systems where python-nbval is not
supported.
<#:phases>: Remove 'relax-requirements' phase.  Pass "-DONNX_BUILD_TESTS" to
CMake depending on tests?.
[native-inputs]: Add python-fb-re2 and python-parameterized-next.  Remove
python-nbval on unsupported systems.
* gnu/packages/patches/onnx-shared-libraries.patch: Adjust patch.
* gnu/packages/patches/onnx-skip-model-downloads.patch: Adjust patch.
* gnu/packages/patches/onnx-use-system-googletest.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Co-authored-by: Andy Tai <atai@atai.org>
2024-09-06 11:46:25 +02:00

14 lines
622 B
Diff

A few tests require downloading models. Skip those.
diff --git a/onnx/backend/test/runner/__init__.py b/onnx/backend/test/runner/__init__.py
index 5b60e7c0..838c7ba5 100644
--- a/onnx/backend/test/runner/__init__.py
+++ b/onnx/backend/test/runner/__init__.py
@@ -236,6 +236,7 @@ class Runner:
print(
f"Start downloading model {model_test.model_name} from {model_test.url}"
)
+ raise unittest.SkipTest('Skipping download')
urlretrieve(model_test.url, download_file.name)
print("Done")
with tarfile.open(download_file.name) as t: