guix/gnu/packages/patches/xpra-6.0-install_libs.patch
Andy Tai 61140300c2
gnu: xpra: Update to 6.0.
* gnu/packages/xorg.scm (xpra): Update to 6.0.
[inputs]: Add xxhash.
[native-inputs]: Change python-cython to python-cython-3.
* gnu/packages/patches/xpra-6.0-install_libs.patch: New file.
* gnu/packages/patches/xpra-6.0-systemd-run.patch: New file.
* gnu/packages/patches/xpra-5.0-install_libs.patch: Removed.
* gnu/packages/patches/xpra-5.0-systemd-run.patch: Removed.
* gnu/local.mk (dist_patch_DATA): Update accordingly

Change-Id: Ic8ec98296220aebabb3d94951e11a3c957a8fcbc
Signed-off-by: Christopher Baines <mail@cbaines.net>
2024-05-14 12:05:25 +01:00

42 lines
1.8 KiB
Diff

Distribution specific patch, not going upstream
This workaround for Gentoo interferes with our use of --no-compile during
the 'install stage.
diff --git a/setup.py b/setup.py
index 4f066fa8bf..14a9ed65ed 100755
--- a/setup.py
+++ b/setup.py
@@ -760,8 +760,6 @@ if modules_ENABLED:
# Utility methods for building with Cython
def do_add_cython_ext(*args, **kwargs):
- if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
- return
if not cython_ENABLED:
raise ValueError(f"cannot build {args}: cython compilation is disabled")
if cython_tracing_ENABLED:
@@ -1971,9 +1969,6 @@ else:
if root_prefix.endswith("/usr"):
# ie: "/" or "/usr/src/rpmbuild/BUILDROOT/xpra-0.18.0-0.20160513r12573.fc23.x86_64/"
root_prefix = root_prefix[:-4]
- for x in sys.argv:
- if x.startswith("--root="):
- root_prefix = x[len("--root="):]
print(f" root_prefix={root_prefix!r}")
build_xpra_conf(root_prefix)
@@ -2116,13 +2111,6 @@ else:
if uinput_ENABLED:
add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
- # gentoo does weird things, calls --no-compile with build *and* install
- # then expects to find the cython modules!? ie:
- #> python2.7 setup.py build -b build-2.7 install --no-compile \
- # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
- # otherwise we use the flags to skip pkgconfig
- if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv): # noqa: E501
- pkgconfig = no_pkgconfig
if OSX and "py2app" in sys.argv:
import py2app #@UnresolvedImport