mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
654de94e74
* gnu/packages/virtualization.scm (qemu)[supported-systems]: Remove the Hurd. * gnu/packages/linux.scm (mdadm)[supported-systems]: Likewise. (lvm2)[supported-systems]: Likewise. (fuse)[supported-systems]: Likewise. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch: New file * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it. [inputs, native-inputs]: Remove non-supported dependencies on non-supported systems. Fixes build for the Hurd.
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
This patch is needed to build Grub on the Hurd.
|
|
|
|
Taken from upstream: https://git.savannah.gnu.org/cgit/grub.git/commit//?id=dabdfa1c6a80639197d05f683a445fa8615517fe
|
|
|
|
From 7606547586b2d6ca1b384e15e0358d3a3ddc48a6 Mon Sep 17 00:00:00 2001
|
|
From: David Michael <fedora.dm0@gmail.com>
|
|
Date: Fri, 5 Jul 2019 07:45:59 -0400
|
|
Subject: verifiers: Blocklist fallout cleanup
|
|
|
|
Blocklist fallout cleanup after commit 5c6f9bc15 (generic/blocklist: Fix
|
|
implicit declaration of function grub_file_filter_disable_compression()).
|
|
|
|
Signed-off-by: David Michael <fedora.dm0@gmail.com>
|
|
Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com>
|
|
|
|
---
|
|
grub-core/osdep/generic/blocklist.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/grub-core/osdep/generic/blocklist.c b/grub-core/osdep/generic/blocklist.c
|
|
index ea2a511b6..2d9040302 100644
|
|
--- a/grub-core/osdep/generic/blocklist.c
|
|
+++ b/grub-core/osdep/generic/blocklist.c
|
|
@@ -59,7 +59,7 @@ grub_install_get_blocklist (grub_device_t root_dev,
|
|
|
|
grub_disk_cache_invalidate_all ();
|
|
|
|
- file = grub_file_open (core_path_dev, GRUB_FILE_TYPE_NONE | FILE_TYPE_NO_DECOMPRESS);
|
|
+ file = grub_file_open (core_path_dev, GRUB_FILE_TYPE_NONE | GRUB_FILE_TYPE_NO_DECOMPRESS);
|
|
if (file)
|
|
{
|
|
if (grub_file_size (file) != core_size)
|
|
@@ -116,7 +116,7 @@ grub_install_get_blocklist (grub_device_t root_dev,
|
|
|
|
grub_file_t file;
|
|
/* Now read the core image to determine where the sectors are. */
|
|
- file = grub_file_open (core_path_dev, GRUB_FILE_TYPE_NONE | FILE_TYPE_NO_DECOMPRESS);
|
|
+ file = grub_file_open (core_path_dev, GRUB_FILE_TYPE_NONE | GRUB_FILE_TYPE_NO_DECOMPRESS);
|
|
if (! file)
|
|
grub_util_error ("%s", grub_errmsg);
|
|
|