mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
976ae7eab6
* gnu/packages/patches/libreoffice-poppler-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libreoffice.scm (libreoffice)[source](patches): New field.
19 lines
918 B
Diff
19 lines
918 B
Diff
Fix type mismatch with Poppler 0.86.
|
|
|
|
Taken from Arch Linux:
|
|
https://git.archlinux.org/svntogit/packages.git/tree/trunk/libreoffice-poppler-0.86.patch?h=packages/libreoffice-fresh
|
|
|
|
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
@@ -563,7 +563,9 @@ void PDFOutDev::processLink(Link* link, Catalog*)
|
|
if (!(pAction && pAction->getKind() == actionURI))
|
|
return;
|
|
|
|
-#if POPPLER_CHECK_VERSION(0, 72, 0)
|
|
+#if POPPLER_CHECK_VERSION(0, 86, 0)
|
|
+ const char* pURI = static_cast<LinkURI*>(pAction)->getURI().c_str();
|
|
+#elif POPPLER_CHECK_VERSION(0, 72, 0)
|
|
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->c_str();
|
|
#else
|
|
const char* pURI = static_cast<LinkURI*>(pAction)->getURI()->getCString();
|