mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-14 19:05:10 -05:00
653569e878
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: Adjust. * gnu/packages/patches/mesa-fix-32bit-test-failures.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove deleted file. * gnu/packages/gl.scm (mesa): Update to 17.1.2. [source]: Remove obsolete patch. [inputs]: Add LIBELF. [native-inputs]: Add WHICH. [arguments]<#:configure-flags>: Adjust deprecated flag.
19 lines
731 B
Diff
19 lines
731 B
Diff
disk_cache_create() here looks up the users home directory from <pwd.h>
|
|
which resolves to "/" in the build environment. I could not find an easy
|
|
way to set the home directory to something else, so we disable this test
|
|
for now.
|
|
|
|
--- a/src/compiler/glsl/tests/cache_test.c
|
|
+++ b/src/compiler/glsl/tests/cache_test.c
|
|
@@ -170,11 +170,6 @@
|
|
unsetenv("MESA_GLSL_CACHE_DIR");
|
|
unsetenv("XDG_CACHE_HOME");
|
|
|
|
- cache = disk_cache_create("test", "make_check");
|
|
- expect_non_null(cache, "disk_cache_create with no environment variables");
|
|
-
|
|
- disk_cache_destroy(cache);
|
|
-
|
|
/* Test with XDG_CACHE_HOME set */
|
|
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
|
|
cache = disk_cache_create("test", "make_check");
|