mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
b0d25a7118
* gnu/packages/patches/tootle-glib-object-naming.patch, gnu/packages/patches/tootle-reason-phrase.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/mastodon.scm (tootle)[source]: Use them. [inputs]: Use LIBSOUP-MINIMAL-2 instead of LIBSOUP. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
48 lines
1.7 KiB
Diff
48 lines
1.7 KiB
Diff
From 858ee78fbebe161a4cdd707a469dc0f045211a51 Mon Sep 17 00:00:00 2001
|
|
From: Max Harmathy <harmathy@mailbox.org>
|
|
Date: Wed, 25 Aug 2021 13:05:58 +0200
|
|
Subject: [PATCH] Use reason_phrase instead of get_phrase
|
|
|
|
---
|
|
src/Services/Cache.vala | 2 +-
|
|
src/Services/Network.vala | 7 +------
|
|
2 files changed, 2 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/src/Services/Cache.vala b/src/Services/Cache.vala
|
|
index 2251697..2ed314e 100644
|
|
--- a/src/Services/Cache.vala
|
|
+++ b/src/Services/Cache.vala
|
|
@@ -88,7 +88,7 @@ public class Tootle.Cache : GLib.Object {
|
|
try {
|
|
var code = msg.status_code;
|
|
if (code != Soup.Status.OK) {
|
|
- var error = network.describe_error (code);
|
|
+ var error = msg.reason_phrase;
|
|
throw new Oopsie.INSTANCE (@"Server returned $error");
|
|
}
|
|
|
|
diff --git a/src/Services/Network.vala b/src/Services/Network.vala
|
|
index fa2839c..d0143b0 100644
|
|
--- a/src/Services/Network.vala
|
|
+++ b/src/Services/Network.vala
|
|
@@ -56,7 +56,7 @@ public class Tootle.Network : GLib.Object {
|
|
else if (status == Soup.Status.CANCELLED)
|
|
debug ("Message is cancelled. Ignoring callback invocation.");
|
|
else
|
|
- ecb ((int32) status, describe_error ((int32) status));
|
|
+ ecb ((int32) status, msg.reason_phrase);
|
|
});
|
|
}
|
|
catch (Error e) {
|
|
@@ -65,11 +65,6 @@ public class Tootle.Network : GLib.Object {
|
|
}
|
|
}
|
|
|
|
- public string describe_error (uint code) {
|
|
- var reason = Soup.Status.get_phrase (code);
|
|
- return @"$code: $reason";
|
|
- }
|
|
-
|
|
public void on_error (int32 code, string message) {
|
|
warning (message);
|
|
app.toast (message);
|