mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-19 05:07:11 -05:00
e8d4c6deaa
* gnu/packages/patches/vlc-qt-5.15.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/video.scm (vlc)[source]: Use it.
56 lines
2.2 KiB
Diff
56 lines
2.2 KiB
Diff
Fix build of VLC with Qt 5.15. Otherwise it fails like this:
|
||
|
||
------
|
||
In file included from gui/qt/util/timetooltip.moc.cpp:10:0:
|
||
gui/qt/util/timetooltip.hpp:49:18: error: field ‘mPainterPath’ has incomplete type ‘QPainterPath’
|
||
QPainterPath mPainterPath;
|
||
^~~~~~~~~~~~
|
||
In file included from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qbrush.h:49:0,
|
||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qpalette.h:46,
|
||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/qwidget.h:48,
|
||
from /gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtWidgets/QWidget:1,
|
||
from gui/qt/util/timetooltip.hpp:27,
|
||
from gui/qt/util/timetooltip.moc.cpp:10:
|
||
/gnu/store/jsxxnsdvij5mrrv6c0kj0261k0f44xlz-qtbase-5.15.2/include/qt5/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
|
||
class QPainterPath;
|
||
^~~~~~~~~~~~
|
||
make[4]: *** [Makefile:25852: gui/qt/util/libqt_plugin_la-timetooltip.moc.lo] Error 1
|
||
------
|
||
|
||
diff --git a/modules/gui/qt/components/playlist/views.cpp b/modules/gui/qt/components/playlist/views.cpp
|
||
index 24db9d9..73c1779 100644
|
||
--- a/modules/gui/qt/components/playlist/views.cpp
|
||
+++ b/modules/gui/qt/components/playlist/views.cpp
|
||
@@ -27,6 +27,7 @@
|
||
#include "input_manager.hpp" /* THEMIM */
|
||
|
||
#include <QPainter>
|
||
+#include <QPainterPath>
|
||
#include <QRect>
|
||
#include <QStyleOptionViewItem>
|
||
#include <QFontMetrics>
|
||
diff --git a/modules/gui/qt/dialogs/plugins.cpp b/modules/gui/qt/dialogs/plugins.cpp
|
||
index d233382..69728eb 100644
|
||
--- a/modules/gui/qt/dialogs/plugins.cpp
|
||
+++ b/modules/gui/qt/dialogs/plugins.cpp
|
||
@@ -53,6 +53,7 @@
|
||
#include <QListView>
|
||
#include <QListWidget>
|
||
#include <QPainter>
|
||
+#include <QPainterPath>
|
||
#include <QStyleOptionViewItem>
|
||
#include <QKeyEvent>
|
||
#include <QPushButton>
|
||
diff --git a/modules/gui/qt/util/timetooltip.hpp b/modules/gui/qt/util/timetooltip.hpp
|
||
index 6a1329e..9f50b18 100644
|
||
--- a/modules/gui/qt/util/timetooltip.hpp
|
||
+++ b/modules/gui/qt/util/timetooltip.hpp
|
||
@@ -25,6 +25,7 @@
|
||
#include "qt.hpp"
|
||
|
||
#include <QWidget>
|
||
+#include <QPainterPath>
|
||
|
||
class TimeTooltip : public QWidget
|
||
{
|
||
|