mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-12-28 07:12:30 -05:00
ee6bb0cc76
* gnu/packages/patches/libxml2-CVE-2015-1819.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch, gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch, gnu/packages/patches/libxml2-CVE-2015-8035.patch, gnu/packages/patches/libxml2-bug-737840.patch, gnu/packages/patches/libxml2-bug-738805.patch, gnu/packages/patches/libxml2-bug-746048.patch, gnu/packages/patches/libxml2-bug-747437.patch, gnu/packages/patches/libxml2-bug-751603.patch, gnu/packages/patches/libxml2-bug-751631.patch, gnu/packages/patches/libxml2-bug-754946.patch, gnu/packages/patches/libxml2-bug-754947.patch, gnu/packages/patches/libxml2-bug-755857.patch, gnu/packages/patches/libxml2-fix-catalog-corruption.patch, gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch, gnu/packages/patches/libxml2-node-sort-order-pt1.patch, gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files. * gnu-system.am (dist_patch_DATA): Add them. * gnu/packages/xml.scm (libxml2)[source]: Add patches.
28 lines
847 B
Diff
28 lines
847 B
Diff
From 41ac9049a27f52e7a1f3b341f8714149fc88d450 Mon Sep 17 00:00:00 2001
|
|
From: Daniel Veillard <veillard@redhat.com>
|
|
Date: Tue, 27 Oct 2015 10:53:44 +0800
|
|
Subject: [PATCH] Fix an error in previous Conditional section patch
|
|
|
|
an off by one mistake in the change, led to error on correct
|
|
document where the end of the included entity was exactly
|
|
the end of the conditional section, leading to regtest failure
|
|
---
|
|
parser.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/parser.c b/parser.c
|
|
index b9217ff..d67b300 100644
|
|
--- a/parser.c
|
|
+++ b/parser.c
|
|
@@ -6916,7 +6916,7 @@ xmlParseConditionalSections(xmlParserCtxtPtr ctxt) {
|
|
NULL, NULL);
|
|
}
|
|
if ((ctxt-> instate != XML_PARSER_EOF) &&
|
|
- ((ctxt->input->cur + 3) < ctxt->input->end))
|
|
+ ((ctxt->input->cur + 3) <= ctxt->input->end))
|
|
SKIP(3);
|
|
}
|
|
}
|
|
--
|
|
2.6.3
|
|
|