mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 07:56:16 -05:00
3837108e40
* gnu/packages/patches/bcftools-regidx-unsigned-char.patch: New file. * gnu/packages/bioinformatics.scm (bcftools)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Register it.
16 lines
483 B
Diff
16 lines
483 B
Diff
Description: Fix test-regidx argument parsing on archs with unsigned char
|
|
On architectures where char is unsigned "c >= 0" was always true.
|
|
Author: Adrian Bunk <bunk@debian.org>
|
|
Bug-Debian: https://bugs.debian.org/865060
|
|
|
|
--- a/test/test-regidx.c
|
|
+++ b/test/test-regidx.c
|
|
@@ -336,7 +336,7 @@
|
|
{"seed",1,0,'s'},
|
|
{0,0,0,0}
|
|
};
|
|
- char c;
|
|
+ int c;
|
|
int seed = (int)time(NULL);
|
|
while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
|
|
{
|