mirror of
https://git.in.rschanz.org/ryan77627/guix.git
synced 2024-11-08 16:06:16 -05:00
8b55544212
* gnu/packages/patches/mesa-skip-disk-cache-test.patch: Rename to ... * gnu/packages/patches/mesa-skip-tests.patch: ... new file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gl.scm (mesa)[source]: Adjust accordingly.
49 lines
1.6 KiB
Diff
49 lines
1.6 KiB
Diff
disk_cache_create() here looks up the users home directory from <pwd.h>
|
|
which resolves to "/" in the build environment. I could not find an easy
|
|
way to set the home directory to something else, so we disable this test
|
|
for now.
|
|
|
|
--- a/src/compiler/glsl/tests/cache_test.c
|
|
+++ b/src/compiler/glsl/tests/cache_test.c
|
|
@@ -170,11 +170,6 @@
|
|
unsetenv("MESA_GLSL_CACHE_DIR");
|
|
unsetenv("XDG_CACHE_HOME");
|
|
|
|
- cache = disk_cache_create("test", "make_check", 0);
|
|
- expect_non_null(cache, "disk_cache_create with no environment variables");
|
|
-
|
|
- disk_cache_destroy(cache);
|
|
-
|
|
/* Test with XDG_CACHE_HOME set */
|
|
setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
|
|
cache = disk_cache_create("test", "make_check", 0);
|
|
|
|
This test fails on i686-linux. I couldn't come up with a regex that
|
|
could be used to disable it just on i686-linux, so we disable it
|
|
completely with this patch:
|
|
|
|
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4091
|
|
|
|
diff --git a/src/util/meson.build b/src/util/meson.build
|
|
index 0893f64..909b3e0 100644
|
|
--- a/src/util/meson.build
|
|
+++ b/src/util/meson.build
|
|
@@ -289,18 +289,6 @@ if with_tests
|
|
suite : ['util'],
|
|
)
|
|
|
|
- test(
|
|
- 'u_debug_stack',
|
|
- executable(
|
|
- 'u_debug_stack_test',
|
|
- files('u_debug_stack_test.cpp'),
|
|
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
|
|
- dependencies : [idep_mesautil, idep_gtest],
|
|
- c_args : [c_msvc_compat_args],
|
|
- ),
|
|
- suite : ['util'],
|
|
- )
|
|
-
|
|
process_test_exe = executable(
|
|
'process_test',
|
|
files('process_test.c'),
|